您的位置:首页 > 其它

poj 2480 Longge's problem(欧拉函数的性质)

2013-08-16 17:34 501 查看
Longge's problem

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 6433Accepted: 2064
Description
Longge is good at mathematics and he likes to think about hard mathematical problems which will be solved by some graceful algorithms. Now a problem comes: Given an integer N(1 < N < 2^31),you are to calculate ∑gcd(i, N) 1<=i <=N.

"Oh, I know, I know!" Longge shouts! But do you know? Please solve it.

Input
Input contain several test case.

A number N per line.

Output
For each N, output ,∑gcd(i, N) 1<=i <=N, a line
Sample Input
2
6

Sample Output
3
15

Source
POJ Contest,Author:Mathematica@ZSU

题意:求 ∑gcd(i, N) 1<=i <=N
题解:涉及欧拉函数,积极函数,莫比乌斯反演等...本弱菜无法说明,搞了很久,但是代码非常短的说.....这大概就是典型的数论题的特征吧....

#include<stdio.h>
int main()
{
long long n,temp,res,i,cou;

while(scanf("%I64d",&n)>0)
{
for(res=1,i=2;i*i<=n;i++)
{
if(n%i!=0) continue;
cou=0;  temp=1;
while(n%i==0){ n/=i; temp*=i; cou++; }
res*=temp/i*(i-1)*cou+temp;
}
if(n>1) res*=2*n-1;
printf("%I64d\n",res);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: