您的位置:首页 > 产品设计 > UI/UE

hdu 1423 Greatest Common Increasing Subsequence (最长上升子序列)

2013-08-06 14:16 399 查看
1、http://acm.hdu.edu.cn/showproblem.php?pid=1423
参考百度文库http://wenku.baidu.com/view/3e78f223aaea998fcc220ea0.html
2、题目大意:
求两个字符串的最大上升子序列,LCIS解决即可

Greatest Common Increasing Subsequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2116 Accepted Submission(s): 638



[align=left]Problem Description[/align]
This is a problem from ZOJ 2432.To make it easyer,you just need output the length of the subsequence.

[align=left]Input[/align]
Each sequence is described with M - its length (1 <= M <= 500) and M integer numbers Ai (-2^31 <= Ai < 2^31) - the sequence itself.

[align=left]Output[/align]
output print L - the length of the greatest common increasing subsequence of both sequences.

[align=left]Sample Input[/align]

1

5
1 4 2 5 -12
4
-12 1 2 4


[align=left]Sample Output[/align]

2


3、代码:
#include<stdio.h>
#include<algorithm>
#include<cstring>
using namespace std;
int main()
{
int t,m,n,a[600],b[600],dp[601][601],i,j,max;
scanf("%d",&t);
while(t--)
{
scanf("%d",&n);
for(i=0;i<n;i++)
scanf("%d",&a[i]);
scanf("%d",&m);
for(i=0;i<m;i++)
scanf("%d",&b[i]);
memset(dp,0,sizeof(dp));

for(i=0;i<n;i++)
{
max=0;
for(j=0;j<m;j++)
{
dp[i+1][j+1]=dp[i][j+1];
if(a[i]>b[j]&&max<dp[i+1][j+1])
max=dp[i+1][j+1];
if(a[i]==b[j])
dp[i+1][j+1]=max+1;

}
}
//printf("%d\n",m);
//for(i=0;i<=m;i++)
//printf("%d\n",dp
[i]);
max=*max_element(dp
,dp
+m+1);
printf("%d\n",max);
if(t!=0)
printf("\n");

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐