您的位置:首页 > 产品设计 > UI/UE

1242Rescue (优先队列BFS)

2013-08-03 22:37 381 查看
[align=left]Problem Description[/align]
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."

Sample Input

7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........

Sample Output

13

#include<stdio.h>
#include<iostream>
#include<queue>
using namespace std;
typedef struct nn
{
int x,y;
int time;
friend bool operator<(nn n1,nn n2)
{
return n2.time<n1.time;
}
}node;
int h,w,si,sj,di,dj,minT,flog;
int dir[4][2]={{1,0},{-1,0},{0,-1},{0,1}};
char map[205][205];
void BFS(void)
{
int tx,ty,e,k,i;
priority_queue<node> Q;
node q,p;

q.time=0;q.x=sj;q.y=si;
Q.push(q);
while(!Q.empty())
{
q=Q.top();
Q.pop();
for(e=0;e<4;e++)
{
tx=q.x+dir[e][1];
ty=q.y+dir[e][0];
if(tx>=0&&tx<w&&ty>=0&&ty<h&&map[ty][tx]!='#')
{
p.time=q.time+1; p.x=tx; p.y=ty;
if(p.y==di&&p.x==dj)
{
minT=p.time;
flog=1;
return ;
}
if(map[ty][tx]=='x')
{
p.time+=1;//printf("#");
}
map[ty][tx]='#';
Q.push(p);
}
}
}
}
int main()
{
int i,j;
while(scanf("%d%d",&h,&w)>0)
{
for(i=0;i<h;i++)
{
getchar();
for(j=0;j<w;j++)
{
scanf("%c",&map[i][j]);
if(map[i][j]=='r')
{
si=i;sj=j;
}
if(map[i][j]=='a')
{
di=i;dj=j;
}
}
}
flog=0;
BFS();
if(flog==0)
printf("Poor ANGEL has to stay in the prison all his life.\n");
else
printf("%d\n",minT);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: