您的位置:首页 > 产品设计 > UI/UE

hdoj 1242 Rescue (bfs 优先队列)

2016-04-01 22:45 357 查看


Rescue

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 24261 Accepted Submission(s): 8557



Problem Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up,
down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."

Sample Input

7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........


Sample Output

13
代码:
#include <cstdio>
#include <queue>
#define max 200+10
using namespace std;
int n,m;
char map[max][max];
int sx,sy,ex,ey;
int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};//四个方向

struct node
{
int x,y,step;
friend bool operator <(node a,node b)
{
return a.step>b.step;
}
}a,temp;//结构体用于自定义优先队列
int bfs()
{
a.x=sx;
a.y=sy;
a.step=0;
priority_queue<node>que;
que.push(a);
while(!que.empty())
{
a=que.top();
que.pop();
if(a.x==ex&&a.y==ey)
{
return a.step;
}
for(int i=0;i<4;i++)
{
temp.x=a.x+dir[i][0];
temp.y=a.y+dir[i][1];
if(temp.x<n&&temp.x>=0&&temp.y<m&&temp.y>=0&&map[temp.x][temp.y]!='#')
{
if(map[temp.x][temp.y]=='.'||map[temp.x][temp.y]=='a')
temp.step=a.step+1;
else
temp.step=a.step+2;
map[temp.x][temp.y]='#';
que.push(temp);
}
}
}
return 0;
}
int main()
{
int ans;
while(scanf("%d%d",&n,&m)!=EOF)
{
for(int i=0;i<n;i++)
scanf("%s",map[i]);
for(int i=0;i<n;i++)
{
for(int j=0;j<m;j++)
{
if(map[i][j]=='r')
{
sx=i;
sy=j;
}
if(map[i][j]=='a')
{
ex=i;
ey=j;
}
}
}
ans=bfs();
if(ans)
printf("%d\n",ans);
else
printf("Poor ANGEL has to stay in the prison all his life.\n");
}
return 0;
}

>>如果r有多个,代码也类似。#include <cstdio>
#include <queue>
#define max 200+10
using namespace std;
int n,m;
char map[max][max];
int sx,sy,ex,ey;
int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};

struct node
{
int x,y,step;
friend bool operator <(node a,node b)
{
return a.step>b.step;//从小到大排列
}
}a,temp;
int bfs()
{
a.x=sx;
a.y=sy;
a.step=0;
priority_queue<node>que;
que.push(a);
while(!que.empty())
{
a=que.top();
que.pop();
if(a.x==ex&&a.y==ey)//找到一个r立即终止
{
return a.step;
}
for(int i=0;i<4;i++)//四个方向
{
temp.x=a.x+dir[i][0];
temp.y=a.y+dir[i][1];
if(temp.x<n&&temp.x>=0&&temp.y<m&&temp.y>=0&&map[temp.x][temp.y]!='#')//满足条件的step增加
{
if(map[temp.x][temp.y]=='.'||map[temp.x][temp.y]=='r')
temp.step=a.step+1;
else
temp.step=a.step+2;
map[temp.x][temp.y]='#';
que.push(temp);
}
}
}
return 0;
}
int main()
{
int ans;
while(scanf("%d%d",&n,&m)!=EOF)
{
for(int i=0;i<n;i++)
scanf("%s",map[i]);
for(int i=0;i<n;i++)
{
for(int j=0;j<m;j++)
{
if(map[i][j]=='a')
{
sx=i;
sy=j;
}
if(map[i][j]=='r')
{
ex=i;
ey=j;
}
}
}
ans=bfs();
if(ans)
printf("%d\n",ans);
else
printf("Poor ANGEL has to stay in the prison all his life.\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: