您的位置:首页 > 其它

UVa 445 Marvelous Mazes(非凡的迷宫)

2013-08-01 22:09 393 查看


 Marvelous Mazes 
Your mission, if you decide to accept it, is to create a maze drawing program. A maze will consist of the alphabetic characters A-Z, * (asterisk), and spaces.

Input and Output

Your program will get the information for the mazes from the input file. This file will contain lines of characters which your program must interpret to draw a maze. Each row of the maze will be described by a series
of numbers and characters, where the numbers before a character tell how many times that character will be used. If there are multiple digits in a number before a character, then the number of times to repeat the character is the sum of the digits before that
character.
The lowercase letter "b" will be used in the input file to represent spaces in the maze. The descriptions for different rows in the maze will be separated by an exclamation point (!) or by an end of
line.

Descriptions for different mazes will be separated by a blank line in both input and output. The input file will be terminated by an end of file.
There is no limit to the number of rows in a maze or the number of mazes in a file, though no row will contain more than 132 characters.
Happy mazing!

Sample Input

1T1b5T!1T2b1T1b2T!1T1b1T2b2T!1T3b1T1b1T!3T3b1T!1T3b1T1b1T!5T1*1T

11X21b1X
4X1b1X


Sample Output

T TTTTT
T  T TT
T T  TT
T   T T
TTT   T
T   T T
TTTTT*T

XX   X
XXXX X


题目解析:

实际上就是一个字符串的展开,将数字与字符分开,这里的数字可能比10大所以在记录数字的时候得注意一下。另外’b‘表示的是空格,’!‘表示的是换行,当句子之间的换行依旧表示换行。

CODE:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

char str[200];

int main()
{
int i, j;
int n;
while(gets(str)!=NULL){    /*读取每一行,对每一行进行翻译*/
n = 0;
for(i = 0; i<strlen(str); i++){
if(str[i]>='0'&&str[i]<='9'){
n += (str[i]-'0');
}
else if(str[i] == 'b'){
for(j = 0; j<n; j++){
printf(" ");
}
n = 0;
}
else if(str[i] == '!'){
printf("\n");
}
else{
for(j = 0; j<n; j++){
printf("%c", str[i]);
}
n = 0;
}
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息