您的位置:首页 > 其它

POJ 2485 Highways【最小生成树最大权——简单模板】

2013-07-31 08:42 531 查看

链接:

http://poj.org/problem?id=2485

http://acm.hust.edu.cn/vjudge/contest/view.action?cid=22010#problem/H

Highways

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 18668Accepted: 8648
Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible
to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town
that is located at the end of both highways.

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.
Input

The first line of input is an integer T, which tells how many test cases followed.

The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between
village i and village j. There is an empty line after each test case.
Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.
Sample Input

1

3
0 990 692
990 0 179
692 179 0

Sample Output

692

Hint

Huge input,scanf is recommended.
Source

POJ Contest,Author:Mathematica@ZSU

题意:

最小生成树的最大权【最小生成树中最长的边】

通:

POJ 1258 Agri-Net 【最小生成树入门题目】

Kruskal:

Accepted820K235MSC++1265B
#include<stdio.h>
#include<algorithm>
using namespace std;

const int maxn = 500+10;

int w[maxn][maxn];
int p[maxn];
int n,m;
int MaxWeight;

struct Edge{
int u,v;
int w;
}edge[maxn*maxn/2];

bool cmp(Edge a, Edge b)
{
return a.w < b.w;
}

int find(int x)
{
return x == p[x] ? x : p[x] = find(p[x]);
}

void Kruskal()
{
for(int i = 1; i <= n; i++) p[i] = i;
sort(edge,edge+m,cmp);

for(int i = 0; i < m; i++)
{
int u = find(edge[i].u);
int v = find(edge[i].v);

if(u != v)
{
p[v] = u;
MaxWeight = max(MaxWeight, edge[i].w);
}
}
}

int main()
{
int T;
scanf("%d", &T);
while(T--)
{
scanf("%d", &n);

for(int i = 1; i <= n; i++)
for(int j = 1; j <= n; j++)
scanf("%d", &w[i][j]);

m = 0;
for(int i = 1; i <= n; i++)
{
for(int j = i+1; j <= n; j++)
{
edge[m].u = i;
edge[m].v = j;
edge[m++].w = w[i][j];
}
}

MaxWeight = 0;
Kruskal();

printf("%d\n", MaxWeight);
}
return 0;
}


Prime:

Accepted580K172MSC++943B
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

const int maxn = 510;
const int INF = 65536*maxn;

int w[maxn][maxn];
int d[maxn];
int vis[maxn];
int n;
int MaxWeight;

void Prime()
{
for(int i = 1; i <= n; i++) d[i] = INF;
d[1] = 0;
memset(vis, 0, sizeof(vis));

for(int i = 1; i <= n; i++)
{
int x, m = INF;
for(int y = 1; y <= n; y++) if(!vis[y] && d[y] <= m) m = d[x=y];
vis[x] = 1; MaxWeight = max(MaxWeight, d[x]);
for(int y = 1; y <= n; y++) if(!vis[y])
d[y] = min(d[y], w[x][y]);
}
}

int main()
{
int T;
scanf("%d", &T);
while(T--)
{
scanf("%d", &n);
for(int i = 1; i <= n; i++)
for(int j = 1; j <= n; j++)
scanf("%d", &w[i][j]);

MaxWeight = 0;
Prime();
printf("%d\n", MaxWeight);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: