您的位置:首页 > 其它

poj 2485 Highways -----最小生成树。prim

2012-05-04 18:04 337 查看
Highways

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 15145Accepted: 7050
Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible
to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town
that is located at the end of both highways.

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed.

The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between
village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input

1

3
0 990 692
990 0 179
692 179 0


Sample Output

692


题目大意: 找出 最小生成树的最大边。

#include<stdio.h>
#include<string.h>
const int MAX=70000;
int map[505][505],vir[505];

int prim(int n);

int main()
{
//freopen("in.txt","r",stdin);
int t,n,i,j;
scanf("%d",&t);
while(t--)
{
memset(vir,0,sizeof(vir));
scanf("%d",&n);
for(i=0;i<n;i++)
for(j=0;j<n;j++)
scanf("%d",&map[i][j]);
printf("%d\n",prim(n));
}
return 0;
}

int prim(int n)
{
int count=0,min,max=0,i,j,temp=n,next;
int p[505];
p[0]=0;
vir[0]=1;
while(--temp)
{
min=MAX;
for(i=0;i<=count;i++)
{
for(j=0;j<n;j++)
{
if(!vir[j] && map[p[i]][j]<min)
{
min=map[p[i]][j];
next=j;
}
}
}
vir[next]=1;
p[++count]=next;
if(min>max) max=min;
//	printf("%d %d %d\n",count , next, max);
}
return max;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: