您的位置:首页 > 其它

HDU1241 Oil Deposits 解题报告--dfs

2013-07-30 21:16 405 查看

Oil Deposits

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7948 Accepted Submission(s): 4672



[align=left]Problem Description[/align]
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots.
It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large
and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

[align=left]Input[/align]
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100
and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

[align=left]Output[/align]
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

[align=left]Sample Input[/align]

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0


[align=left]Sample Output[/align]

0
1
2
2


[align=left]Source[/align]
Mid-Central USA 1997

[align=left]Recommend[/align]
Eddy
#include<iostream>
using namespace std;
int go[8][2]={0,1,1,1,1,0,1,-1,0,-1,-1,-1,-1,0,-1,1};//上,右上,右,右下,下,左下,左,左上
char map[101][101];//油田大小
int flag;//行列数,标志
int m,n;
void dfs(int x,int y)
{
for(int i=0;i<8;i++)//八个方位
{
int nx=x+go[i][0],ny=y+go[i][1];//孩子位置
if(nx>=0&&nx<=n-1&&ny>=0&&ny<=m-1&&map[nx][ny]=='@')//如果孩子是@开始清洗
{
map[nx][ny]='*';//凡是@全清洗为*
dfs(nx,ny);//递归下去
}
}
return  ;
}
int main()
{
while(cin>>n>>m)
{
if(m==0&&n==0) break;
for(int i=0;i<n;i++)
{
for(int j=0;j<m;j++)
{
char e;
cin>>e;
map[i][j]=e;
}
}
int r=0;
for(i=0;i<n;i++)
{
for(int j=0;j<m;j++)
{
if(map[i][j]=='@')
{
dfs(i,j);
r++;
}
}
}
cout<<r<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: