您的位置:首页 > 其它

poj 3617 Best Cow Line

2017-01-01 01:56 351 查看
Best Cow Line

Description

FJ is about to take his N (1 ≤
N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD).
After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows' names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the
end of the new line. When he's finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

* Line 1: A single integer: N
* Lines 2..N+1: Line
i+1 contains a single initial ('A'..'Z') of the cow in the
ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows ('A'..'Z') in the new line.

Sample Input
6
A
C
D
B
C
B

Sample Output
ABCBCD


题意:一组数据,从大写英文组成的字符串a头部或尾部删去一个字符添加到b的尾部,使其字典序尽可能小;
思路:当删去字符时,字符串a正序和倒序哪个更小,则删去其序列下的首字符;
          (本题有个PE坑,80个字符占一行);

#include<stdio.h>

#include<string.h>

#include<algorithm>

using namespace std;

char a[2000],b[2000];

int main()

{

 int t,i,j,p,res=0;

 scanf("%d",&t);

 for(i=0;i<t;i++)

 {

     getchar();

  scanf("%c",&a[i]);

 }

 p=0;j=t-1;

 while(j>=p)

 {

  bool flag=false;

  for(i=0;i+p<=j;i++)//dianjingzhibi

  {

   if(a[i+p]>a[j-i])

   {

    flag=false;

    break;

   }

   else if(a[i+p]<a[j-i])

   {

    flag=true;

    break;

   }

  }

  if(flag)

  {

   b[res++]=a[p++];

  }

  else b[res++]=a[j--];

  if(res==80)

  {

   b[res++]='\0';

   puts(b);

   res=0;

  }

 }

 if(res)

 {

  b[res++]='\0';

  puts(b);

 }

 return 0;

}

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: