您的位置:首页 > 其它

HDU 2147 kiki's game 解题报告

2013-07-16 02:48 411 查看


kiki's game

Problem Description

Recently kiki has nothing to do. While she is bored, an idea appears in his mind, she just playes the checkerboard game.The size of the chesserboard is n*m.First
of all, a coin is placed in the top right corner(1,m). Each time one people can move the coin into the left, the underneath or the left-underneath blank space.The personwho can't
make a move will lose the game. kiki plays it with ZZ.The game always starts with kiki. If both play perfectly, who will win the game?

Input

Input contains multiple test cases. Each line contains two integer n, m (0<n,m<=2000). The input is terminated when n=0 and m=0.

Output

If kiki wins the game printf "Wonderful!", else "What a pity!".

Sample Input

5 3
5 4
6 6
0 0


Sample Output

What a pity!
Wonderful!
Wonderful!


解法:
步骤1:将所有终结位置标记为必败点(P点);

步骤2: 将所有一步操作能进入必败点(P点)的位置标记为必胜点(N点)

步骤3:如果从某个点开始的所有一步操作都只能进入必胜点(N点) ,则将该点标记为必败点(P点) ;

步骤4: 如果在步骤3未能找到新的必败(P点),则算法终止;否则,返回到步骤2。

最开始看到解法首先想到的是用数组,无奈2000*2000的数组太大了,开全局都承受不了,于是在找规律。发现:

凡是n为奇数的那一行全部为N;凡是n为偶数的那一行都以2开头2 1循环出现(如图):



具体的话就自己观察吧

题目分析(设置标记点)代码:(2=P,N=1;)

#include<stdio.h>
int s[2000][2000];
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)!=EOF)
{
int i,j;
s
[1]=2;
for(i=n-1;i>0;i--)
{
if(s[i+1][1]==2)
s[i][1]=1;
else s[i][1]=2;
}
for(j=2;j<=m;j++)
{
if(s
[j-1]==2)
s
[j]=1;
else s
[j]=2;
}
for(i=n-1;i>0;i--)
for(j=2;j<=m;j++)
{
if(s[i][j-1]==2||s[i+1][j]==2||s[i+1][j-1]==2)
s[i][j]=1;
else s[i][j]=2;
}
for(i=1;i<=n;i++)
{
for(j=1;j<=m;j++)
printf("%3d",s[i][j]);
printf("\n");
}
}

return 0;
}


题目AC代码:

#include<stdio.h>
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)&&m&&n)
{
if(n%2)
{
if(m%2)
printf("What a pity!\n");
else
printf("Wonderful!\n");
}
else

printf("Wonderful!\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: