您的位置:首页 > 其它

杭电ACM HDU 3752 Is the one been second-killed first?

2013-07-07 12:53 423 查看

Is the one been second-killed first?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 798 Accepted Submission(s): 544



Problem Description
Long long ago, a problem was spread all over the world , but no one could solve it . Now, due to the Internet , it has been solved perfectly(See figure 1).



Now here’s a problem much harmonious.

ErEr has big cake weighing m grams , at the same time he has n children . and every children want a part of the cake weighs even number(偶数) of grams. The children are extremely hungry and want to start their meal as soon as possible, that's why you should help
them and find out, if they can divide the cake in the way they want. For sure, each of them should get a part of positive weight.



Input
The first line of input gives the number of cases, T (at most 100).

each case has there numbers m,n. (1<=m<=10000,1<=n<=100)



Output
Print YES, if the boys can divide the cake into n parts, each of them weighing even number of kilos; and NO in the opposite case.



Sample Input
2
10 2
11 2




Sample Output
YES
NO




Author
ReDow



Source
HDU 3rd “Vegetable-Birds Cup” Programming Open Contest



Recommend
lcy





#include <stdio.h>
int main(){
    int t,m,n;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&m,&n);
        printf("%s\n",(m%n==1||m/2<n)?"NO":"YES");
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐