您的位置:首页 > 其它

hdu 1087 Super Jumping! Jumping! Jumping!(LIS变形题,求上升子序列的最大和)

2013-04-11 10:09 417 查看
1、http://acm.hdu.edu.cn/showproblem.php?pid=1087

2、题目大意:

有一种游戏,人可以从一个棋子的位置走向另一个棋子的位置,每个棋子都有一个权值,可以一步跳过多个棋子,但是必须保证每个棋子的权值都比前边的权值大,且不能走回头路

开始按照LIS做的,一直wrong,看了网上的代码才过的

3、

Super Jumping! Jumping! Jumping!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 15792 Accepted Submission(s): 6714



[align=left]Problem Description[/align]
Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.



The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In
the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping
can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his
jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.

Your task is to output the maximum value according to the given chessmen list.

[align=left]Input[/align]
Input contains multiple test cases. Each test case is described in a line as follow:

N value_1 value_2 …value_N

It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.

A test case starting with 0 terminates the input and this test case is not to be processed.

[align=left]Output[/align]
For each case, print the maximum according to rules, and one line one case.

[align=left]Sample Input[/align]

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0


[align=left]Sample Output[/align]

4
10
3


4、ac代码:

#include<stdio.h>
#define N 1005
int a
;
int dp
;
int main()
{
int n;
while(scanf("%d",&n))
{
if(n==0)
break;
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
dp[i]=a[i];
}
for(int i=1;i<=n;i++)
{
for(int j=1;j<i;j++)
{
if(a[i]>a[j]&&a[i]+dp[j]>dp[i])
dp[i]=dp[j]+a[i];
}
}
int maxx=-1;
for(int i=1;i<=n;i++)
{
if(dp[i]>maxx)
maxx=dp[i];
}
printf("%d\n",maxx);
}
return 0;
}


2、wrong 的代码,待改正:

#include<stdio.h>
#include<string.h>
#define N 1005
long long stack
;
long long dp
;
int a
;
int b
;
long long maxx;
void LIS(int n)
{
int top=0;
long long sum=0;
memset(stack,0,sizeof(stack));
stack[top]=-1;
maxx=-1;
for(int i=1;i<=n;i++)
{
if(a[i]>stack[top])
{
stack[++top]=a[i];
dp[i]=top;
}
else
{
int l=1,r=top;
while(l<=r)
{
int mid=(l+r)>>1;
if(a[i]<stack[mid])
r=mid-1;
else
l=mid+1;
}
stack[r]=a[i];
dp[i]=r;
//printf("l=%d\n",r);
}
sum=0;
for(int j=1;j<=dp[i];j++)
{
sum+=stack[j];
}
if(sum>maxx)
{
memset(b,0,sizeof(b));
for(int j=1;j<=dp[i];j++)
{
b[j]=stack[j];
}
maxx=sum;
}//printf("%d\n",maxx);
}
}
int main()
{
int n;
while(scanf("%d",&n))
{
if(n==0)
break;
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
}
LIS(n);
printf("%lld\n",maxx);
}
return 0;
}
/*
3 1 3 2 4 1 2 3 4 4 3 3 2 1 0
*/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐