您的位置:首页 > 其它

HDU1379:DNA Sorting

2013-01-18 11:03 155 查看
Problem Description
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters
to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)--it is nearly sorted--while the sequence ``ZWQM'' has 6 inversions (it is
as unsorted as can be--exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''.
All the strings are of the same length.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.



Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (1 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string
of length n.



Output
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. If two or more strings are equally sorted, list them in the same order they are in the input file.



Sample Input
1

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT




Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA








一直没弄懂题意,看了人家的解题报告才知道,原来就是看每个字母后面有几个字母比它大,然后再把数目全加起来,按总和的升序排列

#include<stdlib.h>
#include<stdio.h>
#include <string>
#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
struct DNA
{
    string str;
    int count;
} w[1001];

bool comp(DNA x,DNA y)
{
    return x.count<y.count;
}

int main()
{
    int s,n,i,j,k,t;
    cin >> t;
    while(t--)
    {
        scanf("%d %d",&s,&n);
        for(i=0; i<n; i++)
        {
            cin>>w[i].str
            w[i].count=0;
            for(j=0; j<=s-2; j++) //**选择排序**//
            {
                for(k=j+1; k<=s-1; k++)
                {
                    if(w[i].str[j]>w[i].str[k]) w[i].count++;
                }
            }
        }
        stable_sort(w,w+n,comp);
        for(i=0; i<n; i++)
        {
            cout<<w[i].str<<endl;
        }
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: