您的位置:首页 > 产品设计 > UI/UE

Windows Message Queue(优先级队列+map)

2012-11-18 11:50 351 查看


Windows Message Queue

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1952 Accepted Submission(s): 759



Problem Description

Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will
do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message
from the message queue.

Input

There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by.
There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

Output

For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.

Sample Input

GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET


Sample Output

EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!


Author

ZHOU, Ran

Source

Zhejiang University Local Contest 2006, Preliminary

Recommend

linle

Statistic | Submit | Discuss | Note

由于优先级相同的采取fifo策略,故要记录每一个message在权值与其相同的所有messages中出现的序号,由于权值可以为较大的数,用数组记录某一权值出现的次数不现实,而用map可以轻松做到这一点,将每一个权值映射到一个计数器,初始为零,每出现一次该权值对应的计数器加1。有关map的用法这里不说,google一下很多资料有介绍。

AC Code:

#include <iostream>
#include <string>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <map>
#include <vector>
#include <queue>
#include <stack>
#define LL long long
#define MAXI 2147483647
#define MAXL 9223372036854775807
#define eps (1e-8)
#define dg(i) cout << "*" << i << endl;
//2724.2212.2511.1731.2334
using namespace std;

struct Message
{
char msg[20];
int pri;  //权值
int par;  //参数
int t;  //记录当前message是具有相同键值的所有message中的第几个
};
priority_queue<Message> Q;
map<int, int> M;

bool operator < (const Message& a, const Message& b)
{
if(a.pri != b.pri) return a.pri > b.pri;
return a.t > b.t;
}

int main()
{
char cmd[4];
while(scanf("%s", cmd) != EOF)
{
if(cmd[0] == 'P')
{
Message newMsg;
scanf("%s %d %d", newMsg.msg, &newMsg.par, &newMsg.pri);
newMsg.t = M[newMsg.pri]++;  //map的作用在此
Q.push(newMsg);
}
else
{
if(Q.empty()) puts("EMPTY QUEUE!");
else
{
Message outMsg = Q.top();
Q.pop();
printf("%s %d\n", outMsg.msg, outMsg.par);
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: