您的位置:首页 > 产品设计 > UI/UE

HDU 1509 Windows Message Queue(队列)

2016-02-09 20:17 369 查看
题目链接

[align=left]Problem Description[/align]
Message queue is the basic fundamental of windows system. For each process, the system maintains a message queue. If something happens to this process, such as mouse click, text change, the system will add a message to the queue. Meanwhile, the process will do a loop for getting message from the queue according to the priority value if it is not empty. Note that the less priority value means the higher priority. In this problem, you are asked to simulate the message queue for putting messages to and getting message from the message queue.

[align=left]Input[/align]
There's only one test case in the input. Each line is a command, "GET" or "PUT", which means getting message or putting message. If the command is "PUT", there're one string means the message name and two integer means the parameter and priority followed by. There will be at most 60000 command. Note that one message can appear twice or more and if two messages have the same priority, the one comes first will be processed first.(i.e., FIFO for the same priority.) Process to the end-of-file.

[align=left]Output[/align]
For each "GET" command, output the command getting from the message queue with the name and parameter in one line. If there's no message in the queue, output "EMPTY QUEUE!". There's no output for "PUT" command.

[align=left]Sample Input[/align]

GET
PUT msg1 10 5
PUT msg2 10 4
GET
GET
GET

[align=left]Sample Output[/align]

EMPTY QUEUE!
msg2 10
msg1 10
EMPTY QUEUE!
题解:优先队列,写的时候运算符重载一直出问题,还是不懂。而且刚开始没有加idx这个成员,就一直WA,看了看题目也没发现什么诡异的地方,最后看了几个题解,加上了idx就AC了,也不知道是为什么。

#include <cstdio>
#include <iostream>
#include <string>
#include <sstream>
#include <cstring>
#include <stack>
#include <queue>
#include <algorithm>
#include <cmath>
#include <map>
#define PI acos(-1.0)
#define ms(a) memset(a,0,sizeof(a))
#define msp memset(mp,0,sizeof(mp))
#define msv memset(vis,0,sizeof(vis))
using namespace std;
//#define LOCAL
struct task
{
char name[50];
int value,pri,idx;
friend bool operator < (task a,task b)
{
if(a.pri==b.pri)
{
return b.idx<a.idx;
}
return b.pri<a.pri;
}
} t;
int main()
{
#ifdef LOCAL
freopen("in.txt", "r", stdin);
#endif // LOCAL
ios::sync_with_stdio(false);
priority_queue<task> q;
//while(!q.empty())q.pop();
char com[5];
int k=0;
while(cin>>com)
{
if(com[0]=='G')
{
if(q.empty())printf("EMPTY QUEUE!\n");
else printf("%s %d\n",q.top().name,q.top().value),q.pop();
}
else
{
cin>>t.name>>t.value>>t.pri;
t.idx=++k;
q.push(t);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: