您的位置:首页 > 产品设计 > UI/UE

动态规划总结五 poj 1458 Common Subsequence(最长公共子序列)

2012-10-13 11:16 441 查看
[align=center]Common Subsequence[/align]

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 29399Accepted: 11387
Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing
sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem
is to find the length of the maximum-length common subsequence of X and Y.

Input
The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output
For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input
abcfbc abfcab programming contest abcd mnp


Sample Output
4 2 0

求两个string的最大公共字串,动态规划的经典问题。算法导论有详细的讲解。
下面以题目中的例子来说明算法:两个string分别为:abcfbc和abfca。创建一个二维数组a[][],维数分别是两个字符串长度加一。我们定义a[i][j]表示Xi和Yj 的最长子串(LCS).当i或j等于0时,a[i][j]=0. LCS问题存在一下递归式:
a[i][j] = 0                            i=0 or j=0
a[i][j] = a[i-1][j-1] +1                Xi= =Yj
a[i][j] = MAX(a[i-1][j], a[i][j-1])  Xi! =Yj
对于以上例子,算法如下:
a[i][j]:

a
b
c
f
b
a
0
1
2
3
4
5
6
0
0
0
0
0
0
0
0
a
1
0
1
1
1
1
1
1
b
2
0
1
2
2
2
2
2
f
3
0
1
2
2
3
3
3
c
4
0
1
2
3
3
3
3
a
5
0
1
2
3
3
3
4
从最后一个格向上顺着箭头的方向可以找到最长子串的构成,在有箭头组成的线段中,含有斜向上的箭头对应的字符是其中的一个lcs。

#include<stdio.h>
#include<string.h>
#define M 400
int max(int a,int b)
{
if(a>=b)
return a;
else
return b;
}
int main()
{
int i,j,a[M][M],len1,len2;
char s1[M],s2[M];
while(scanf("%s %s",s1+1,s2+1)!=EOF)
{
len1=strlen(s1+1);
len2=strlen(s2+1);
memset(a,0,sizeof(a));
for(i=1;i<=len1;i++)
for(j=1;j<=len2;j++)
{
if(s1[i]==s2[j])
a[i][j]=a[i-1][j-1]+1;
else if(s1[i]!=s2[j])
a[i][j]=max(a[i][j-1],a[i-1][j]);
}
printf("%d\n",a[len1][len2]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: