您的位置:首页 > 其它

hdu Can you solve this equation?

2012-08-31 21:05 197 查看

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 412 Accepted Submission(s): 237
[align=left]Problem Description[/align]
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100; Now please try your lucky.

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

[align=left]Output[/align]
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

[align=left]Sample Input[/align]

2
100
-4


[align=left]Sample Output[/align]

1.6152
No solution!


[align=left]Author[/align]
Redow

[align=left]Recommend[/align]
lcy
分析:典型二分,注意eps取值要恰当

#include<cmath>
#include<cstdio>
#define eps 1e-8
double fun(double x)
{
return 8*x*x*x*x + 7*x*x*x + 2*x*x + 3*x + 6;
}
int main()
{
double y,a,b,m,d;
int T;
scanf("%d",&T);
while(T--)
{
scanf("%lf",&y);
if(y<6 || y>807020306)
{
printf("No solution!\n");
continue;
}
a=0.0;
b=100.0;
while(b-a>eps)
{
m=(a+b)/2;
if(fun(m)<y)
a=m;
else
b=m;
}
printf("%.4f\n",a);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: