您的位置:首页 > 运维架构

UVa 714 - Copying Books,最大值最小化问题

2012-08-15 00:07 393 查看
链接:

http://uva.onlinejudge.org/index.php?option=com_onlinejudge&Itemid=8&category=113&page=show_problem&problem=655

原题:

Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had to be re-written by hand by so called scribers. The scriber had been given a book and after
several months he finished its copy. One of the most famous scribers lived in the 15th century and his name was Xaverius Endricus Remius Ontius Xendrianus (Xerox). Anyway, the work was very annoying and boring. And the only way to speed it up was
to hire more scribers.

Once upon a time, there was a theater ensemble that wanted to play famous Antique Tragedies. The scripts of these plays were divided into many books and actors needed more copies of them, of course. So they hired many scribers to make copies of these books.
Imagine you have m books (numbered

) that may have different number of pages (

)
and you want to make one copy of each of them. Your task is to divide these books among k scribes,

. Each book can be assigned
to a single scriber only, and every scriber must get a continuous sequence of books. That means, there exists an increasing succession of numbers

such
that i-th scriber gets a sequence of books with numbers between bi-1+1 and bi. The time needed to make a copy of all the books is determined by the scriber who was assigned the most work. Therefore,
our goal is to minimize the maximum number of pages assigned to a single scriber. Your task is to find the optimal assignment.

Input

The input consists of N cases. The first line of the input contains only positive integer N. Then follow the cases. Each case consists of exactly two lines. At the first line, there are
two integers m and k,

. At the second line, there are integers

separated
by spaces. All these values are positive and less than 10000000.

Output

For each case, print exactly one line. The line must contain the input succession

divided
into exactly k parts such that the maximum sum of a single part should be as small as possible. Use the slash character (`/') to separate the parts. There must be exactly one space character between any two successive numbers and between
the number and the slash.

If there is more than one solution, print the one that minimizes the work assigned to the first scriber, then to the second scriber etc. But each scriber must be assigned at least one book.

Sample Input

2
9 3
100 200 300 400 500 600 700 800 900
5 4
100 100 100 100 100


Sample Output

100 200 300 400 500 / 600 700 / 800 900
100 / 100 / 100 / 100 100


题目大意:
要抄N本书,编号为1,2,3...N, 每本书有1<=x<=10000000页, 把这些书分配给K个抄写员,要求分配给某个抄写员的那些书的编号必须是连续的。每个抄写员的速度是相同的,求所有书抄完所用的最少时间的分配方案。

分析与总结:
所化的总时间取决于所有抄写员中任务最多的那个,是经典的最大值最小化问题。LRJ《算法入门经典》P151页有介绍:



在这题中,需要注意的是求和时用32位int可能会溢出,所以要用long long.

代码:

/*
 * UVa: 714 - Copying Books
 * Time: 0.008s
 * Author: D_Double
 *
 */
#include<cstdio>
#include<cstring>
#define MAXN 505
using namespace std;
int m, k;
long long arr[MAXN], sum, min, ans;
bool vis[MAXN];

inline int divide(long long M){
    memset(vis, 0, sizeof(vis));
    int cnt=0;
    int pos=m-1;
    while(pos>=0){
        long long sum=0;
        bool ok=true;
        while(pos>=0 && sum+arr[pos]<=M){
            ok=false;
            sum += arr[pos];
            --pos;
        }
        if(ok){
            return k+1; // 返回一个大于k的数
        }
        if(pos>=0) vis[pos] = true;
        ++cnt;
    }
    return cnt;
}

long long binary(){
    long long left=min, right=sum, mid;
    while(left<right){
        mid = (left+right)>>1;
        if(divide(mid)<=k) 
            right=mid;
        else 
            left=mid+1;
    }
    return right;
}

inline void output(){
    int cnt=divide(ans);
    for(int i=0; i<m-1&&cnt<k; ++i)if(!vis[i]){
        vis[i]=true;
        ++cnt;
    } 
    for(int i=0; i<m; ++i){
        if(i) printf(" %lld",arr[i]);
        else printf("%lld",arr[i]);
        if(vis[i]){
            printf(" /");
        }
    }
    puts("");
}

int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%d%d",&m,&k);
        sum=0;  min=0;
        for(int i=0; i<m; ++i){
            scanf("%lld",&arr[i]);
            sum += arr[i];
            if(arr[i]>min) min=arr[i];
        }
        ans=binary();
        output();
    }
    return 0;
}


——  生命的意义,在于赋予它意义。               原创 http://blog.csdn.net/shuangde800 , By   D_Double  (转载请标明)
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: