您的位置:首页 > 其它

【I - ECJTU_ACM 11级队员2012年暑假训练赛(2)】

2012-07-10 15:48 471 查看
I - I
Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u
Submit Status

Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output

For each integer in the input, output its digital root on a separate line of the output.

Sample Input

24
39
0

Sample Output

6
3

// Project name : I
// File name    : main.cpp
// Author       : Izumu
// Date & Time  : Tue Jul 10 14:50:07 2012

#include <iostream>
#include <stdio.h>
#include <string>
#include <cmath>
using namespace std;

int main()
{
string s;
while (cin >> s && s != "0")
{
int n = 0;
int top = 0;
while (s[top] != '\0')
{
n += (s[top] - '0');
top++;
}

int sum = n;
while (sum >= 10)
{
sum = (sum / 10) + sum % 10;
}
cout << sum << endl;
}
return 0;
}

// end
// ism
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: