您的位置:首页 > 其它

【D - ECJTU_ACM 11级队员2012年暑假训练赛(2)】

2012-07-10 15:45 330 查看
D - D
Time Limit:1000MS Memory Limit:65536KB 64bit IO Format:%I64d & %I64u
Submit Status

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is


.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fnmod 10000).

Sample Input

0
9
999999999
1000000000
-1


Sample Output

0
34
626
6875


Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by


.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:


.

// Project name : D ( Fibonacci )
// File name    : main.cpp
// Author       : Izumu
// Date & Time  : Tue Jul 10 14:02:23 2012

#include <iostream>
#include <stdio.h>
using namespace std;

int p[30][4]={1,1,1,0};

void mm(int * ret,int * a,int * b)
{
int x[4],y[4],i;
for(i=0;i<4;i++)
{
x[i]=a[i];
y[i]=b[i];
}
ret[0] = (x[0]*y[0] + x[1]*y[2]) % 10000;
ret[1] = (x[0]*y[1] + x[1]*y[3]) % 10000;
ret[2] = (x[2]*y[0] + x[3]*y[2]) % 10000;
ret[3] = (x[2]*y[1] + x[3]*y[3]) % 10000;
}

int main()
{
int i,n;
int a[4]={0,1,1,0};
for(i=1;i<30;i++)
{
mm(p[i],p[i-1],p[i-1]);
}
while(1)
{
scanf("%d",&n);
if(n==-1) break;
a[0]=1;a[1]=0;a[2]=0;a[3]=1;

for(i=0;i<30;i++)
{
if(n&(1<<i))
{
mm(a,a,p[i]);
}
}
cout << a[1] << endl;
}

return 0;
}

// end
// ism
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: