您的位置:首页 > 其它

最小生成树 POJ——Truck History(没看懂题,直接根据测试用例YY的,我的Kusal 写法复习)

2012-06-16 19:59 344 查看
Truck History

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 11920Accepted: 4490
Description
Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string
of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company's history, just a single truck type was used but later other types were derived from it, then from
the new types another types were derived, and so on.

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different
letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as

1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types.

Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan.

Input
The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase
letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.
Output
For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.
Sample Input
4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output
The highest possible quality is 1/3.

/*

* File: main.cpp

* Author: hit-acm

*

* Created on 2012年6月16日, 下午7:05

*

/*从这里可以看出来,Prime算法对于稠密图比Kusal算法要高效很多!*/

#include <iostream>

#include <cstdio>

#include <cstring>

#include <algorithm>

#include <cmath>

using namespace std;

const int MAX = 2011;

char c[MAX][10];

int father[MAX];

struct p {

int x, y;

int dis;

bool operator<(const p & a)const {

return dis < a.dis;

}

} pp[MAX*(MAX - 1) / 2];

void init() {

for (int i = 0; i < MAX; i++) {

father[i] = i;

}

}

int find_ancest(int x) {

if (x == father[x]) return x;

return father[x] = find_ancest(father[x]);

}

int MST(int size) {

init();

sort(pp, pp + size);

int u, v;

int res = 0;

for (int i = 0; i < size; i++) {

u = find_ancest(pp[i].x);

v = find_ancest(pp[i].y);

if (u != v) {

father[u] = v;

res += pp[i].dis;

}

}

return res;

}

int get_dis(char *c1, char *c2) {

int ans = 0;

for (int i = 0; i < 7; i++) {

if (c1[i] != c2[i]) ans++;

}

return ans;

}

int main() {

int N;

while (scanf("%d", &N) && N) {

int size = 0;

for (int i = 0; i < N; i++) {

scanf(" %s", &c[i]);

for (int j = 0; j < i; j++) {

pp[size].x = i;

pp[size].y = j;

pp[size].dis = get_dis(c[i], c[j]);

size++;

}

}

printf("The highest possible quality is 1/%d.\n", MST(size));

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: