您的位置:首页 > 理论基础

2011年浙江大学计算机及软件工程研究生机试真题(1)

2012-04-21 20:09 471 查看
题目描述:

This time, you are supposed to find A+B where A and B are two matrices, and then count the number of zero rows and columns.

输入:

The input consists of several test cases, each starts with a pair of positive integers M and N (≤10) which are the number of rows and columns of the matrices, respectively. Then 2*M lines follow, each contains N integers
in [-100, 100], separated by a space. The first M lines correspond to the elements of A and the second M lines to that of B.

The input is terminated by a zero M and that case must NOT be processed.

输出:

For each test case you should output in one line the total number of zero rows and columns of A+B.

样例输入:
2 2
1 1
1 1
-1 -1
10 9
2 3
1 2 3
4 5 6
-1 -2 -3
-4 -5 -6
0


样例输出:
1
5


AC代码:

#include<iostream>
using namespace std;

int main(){
int i,j,m,n,num,flag,num1[10][10],num2[10][10],result[10][10];

while(cin>>m){
if(m==0)
break;
cin>>n;
for(i=0;i<m;i++)
for(j=0;j<n;j++)
cin>>num1[i][j];
for(i=0;i<m;i++)
for(j=0;j<n;j++)
cin>>num2[i][j];

/*for(i=0;i<m;i++)
for(j=0;j<n;j++)
result[i][j]=num1[i][j]+num2[i][j];
*/

num=0;
for(i=0;i<m;i++){
flag=0;
for(j=0;j<n;j++)
if(num1[i][j]+num2[i][j]){
flag=1;
break;
}
if(flag==0)
num++;
}

for(i=0;i<n;i++){
flag=0;
for(j=0;j<m;j++)
if(num1[j][i]+num2[j][i])
{
flag=1;
break;
}
if(flag==0)
num++;
}
cout<<num<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐