您的位置:首页 > 大数据 > 人工智能

POJ 1575 Easier Done Than Said?(我的水题之路——三重标记)

2012-01-31 01:53 387 查看
Easier Done Than Said?

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 3387Accepted: 1873
Description

Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering them
and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" passwords that are relatively secure but still easy to remember.

FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

It must contain at least one vowel.

It cannot contain three consecutive vowels or three consecutive consonants.

It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'.

(For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that these rules are not perfect; there are many common/pronounceable words that are not acceptable.

Input

The input consists of one or more potential passwords, one per line, followed by a line containing only the word 'end' that signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.

Output

For each password, output whether or not it is acceptable, using the precise format shown in the example.

Sample Input
a
tv
ptoui
bontres
zoggax
wiinq
eep
houctuh
end


Sample Output
<a> is acceptable.
<tv> is not acceptable.
<ptoui> is not acceptable.
<bontres> is not acceptable.
<zoggax> is not acceptable.
<wiinq> is not acceptable.
<eep> is acceptable.
<houctuh> is acceptable.


Source

Mid-Central USA 2000

对题中给出的字符串进行判断,需要符合如下三个要求则认为这个字符串AC,否则 not AC:

1)字符串中不能没有元音,即a, e, i, o, u

2)字符串中不能有三个元音或辅音连续。

3)字符串中不能有除了“ee"和”oo”以外的两个连续相同的字符。

运用三种标记,分别标记三种情况。对每一次字符读入均进行判断,如果有不符合条件的,就直接退出循环。

注意点:

1)在没有明确规定的题目中,这种多标记会很麻烦,必须先屡清楚思路再编码

代码(1AC):

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <string>

using namespace std;

char availdou[5] = "eo";
char str[30];
int words[26];

int main(void){
int vowelflag = 0;
int douflag;
char douch;
int tripleflag;
int len, i;

for (i = 0; i < 26; i++){
if ('a' + i == 'a' ||'a' + i == 'e' || 'a' + i == 'i' || 'a' + i == 'o' || 'a' + i == 'u'){
words[i] = 1;
}

else{
words[i] = 0;
}
}
while (scanf("%s", str), strcmp(str, "end") != 0){
vowelflag = 1;
douflag = tripleflag = 0;
douch = '\0';
len = strlen(str);
for (i = 0; i < len; i++){
if (words[str[i] - 'a'] == 1){
vowelflag = 0;
if (tripleflag <= 0){
tripleflag = 1;
}
else if (tripleflag <= 2){
tripleflag ++;
}
//printf("%d: triple1:%d\n", i, tripleflag);
if (tripleflag == 3){
break;
}
if (douch == str[i]){
if (!(douch == 'e' || douch == 'o')){
douflag = 1;
break;
}
}
douch = str[i];
}
else if (words[str[i] - 'a'] == 0){
if (tripleflag >= 0){
tripleflag = -1;
}
else if (tripleflag >= -2){
tripleflag --;
}
//printf("%d: triple2:%d\n", i, tripleflag);
if (tripleflag == -3){
break;
}
if (douch == str[i]){
douflag = 1;
break;
}
douch = str[i];
}
}
if (tripleflag == 3 || tripleflag == -3 || douflag || vowelflag){
printf("<%s> is not acceptable.\n", str);
}
else{
printf("<%s> is acceptable.\n", str);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: