您的位置:首页 > 编程语言 > Go语言

(POJ 1003)Hangover

2011-04-13 10:44 330 查看
Hangover
 

 

Description

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below. 
 


 

 

Input

The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.
Output

For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.
Sample Input

1.00 3.71 0.04 5.19 0.00
Sample Output

3 card(s) 61 card(s) 1 card(s)273 card(s)
Source

Mid-Central USA 2001 

AC code:
#include<stdio.h>
main()
{
float a,result=0;
int n = 2;
scanf("%f",&a);
while(a!=0)
{
for (n=2,result=0; result<a; n++)
{
result += 1.0 / n;
}
printf("%d card(s)/n",n-2);
scanf("%f",&a);
}
}
 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  output input table each float c