您的位置:首页 > 编程语言 > Go语言

POJ-1003:Hangover

2012-01-17 22:33 351 查看


1003:Hangover

时间限制:
1000ms
内存限制:
65536kB

描述

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the
bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make ncards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1)
card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.



输入
The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will
contain exactly three digits.
输出
For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.
样例输入
1.00
3.71
0.04
5.19
0.00


样例输出
3 card(s)
61 card(s)
1 card(s)
273 card(s)


热手性质的一道题,实质就是计算1/2+1/3+4/1+1/5+……+1/n的值 大于等于某个给定值的时候的 级数的项数,可以直接穷举暴力解。

#include <stdio.h>
#include <math.h>
int main()
{
float i;
while(scanf("%f",&i)==1)
{
if(i<0.01 || i>5.20 )
{   return 0;   }
float tmp    = 0;
float length = 0;
int   number = 1;
while(tmp < i)
{
length = 1.0/++number;
tmp += length;
}
int card = number - 1;
printf("%d card(s)\n",  card);
}

return 0;
}


另外,也可有数学解法,因为这个一个调和级数,所有有



其中γ是欧拉-马歇罗尼常数,而

约等于

,并且随着k 趋于正无穷而趋于0。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: