您的位置:首页 > 编程语言 > PHP开发

HDUOJ1312 Red and Black

2011-04-03 19:51 183 查看

Red and Black

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2083    Accepted Submission(s): 1356


Problem Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 
 

Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
 

Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself). 
 

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

 

Sample Output

45
59
6
13

 

【解题思路】像四个方向搜索可达的.的数量,并吧访问过的标记为#

 

 

 

 

#include<iostream>
#include<stdio.h>
using namespace std;
#define N 21
char arc

;
int set

, w, h;
int d[4][2] = { { -1, 0 }, { 1, 0 }, { 0, 1 }, { 0, -1 } };
int k;
int dfs(int x, int y) {
arc[x][y] = '#';
for (int i = 0; i < 4; i++) {
int px = x + d[i][0];
int py = y + d[i][1];
if (px >= 0 && py >= 0 && px < h && py < w && arc[px][py] != '#') {
k++;
dfs(px, py);
}
}
return k;
}
int main() {
int i, j;
int x, y;
while (cin >> w >> h && w && h) {
k = 1;
for (i = 0; i < h; i++)
for (j = 0; j < w; j++) {
cin >> arc[i][j];
if (arc[i][j] == '@') {
x = i;y = j;
}
}
cout << dfs(x, y) << endl;
}
return 0;
}
 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息