您的位置:首页 > 编程语言 > PHP开发

POJ 1129 Channel Allocation DFS搜索 着色问题

2010-12-19 20:22 423 查看
 

该题的大体意思是,有几个广播站,相邻的广播站不同用相同的颜色

实际就是着色问题,这里着色的是边的着色

 

 

Channel Allocation

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 7070 Accepted: 3606
Description

When a radio station is broadcasting over a very large area, repeaters are used to retransmit the signal so that every receiver has a strong signal. However, the channels used by each repeater must be carefully chosen so that nearby repeaters do not interfere with one another. This condition is satisfied if adjacent repeaters use different channels. 

 

Since the radio frequency spectrum is a precious resource, the number of channels required by a given network of repeaters should be minimised. You have to write a program that reads in a description of a repeater network and determines the minimum number of channels required.

Input

The input consists of a number of maps of repeater networks. Each map begins with a line containing the number of repeaters. This is between 1 and 26, and the repeaters are referred to by consecutive upper-case letters of the alphabet starting with A. For example, ten repeaters would have the names A,B,C,...,I and J. A network with zero repeaters indicates the end of input. 

 

Following the number of repeaters is a list of adjacency relationships. Each line has the form: 

 

A:BCDH 

 

which indicates that the repeaters B, C, D and H are adjacent to the repeater A. The first line describes those adjacent to repeater A, the second those adjacent to B, and so on for all of the repeaters. If a repeater is not adjacent to any other, its line has the form 

 

A: 

 

The repeaters are listed in alphabetical order. 

 

Note that the adjacency is a symmetric relationship; if A is adjacent to B, then B is necessarily adjacent to A. Also, since the repeaters lie in a plane, the graph formed by connecting adjacent repeaters does not have any line segments that cross. 

Output
For each map (except the final one with no repeaters), print a line containing the minumum number of channels needed so that no adjacent channels interfere. The sample output shows the format of this line. Take care that channels is in the singular form when only one channel is required.

Sample Input
2
A:
B:
4
A:BC
B:ACD
C:ABD
D:BC
4
A:BCD
B:ACD
C:ABD
D:ABC
0

Sample Output
1 channel needed.
3 channels needed.
4 channels needed.

/* Author yan
* POJ 1129
* Channel Allocation
*/
//POJ 的第一个着色题,学习!!!
#include<stdio.h>
int map[27][27];//存放各个广播站的相邻情况
int opt[27];//存放不同广播站"着色"的结果

int n;
/*
**参数int poi,表示广播站
**该函数用于判断与本广播站相邻的所有广播站的着色颜色里面是否包含某种颜色
**返回值
**返回1代表相邻的广播站有这种颜色,因此在DFS()函数调用的时候需要需要换另一种颜色,即 opt[start]++
**返回0代表相邻的广播站没有这种颜色
*/
int same(int poi)
{
int _i;
for(_i=0;_i<n;_i++)
{
if(map[_i][poi]==1 && opt[_i]==opt[poi]) return 1;
}
return 0;
}
/*
**核心函数,深度优先搜索
**递归出口:start==n,表示所有的着色完毕
**循环:对某个点的颜色进行枚举,如果没有找到某个相同的颜色,则换另一种颜色,继续着色(start+1)点
*/
int DFS(int start,int maxcolor)
{
//printf(">>/n");
if(start==n) return n;
for(opt[start]=1;opt[start]<=maxcolor;opt[start]++)
{
if(!same(start)) return DFS(start+1,maxcolor);
}
return 0;
}
int main()
{
int i,j;
char cache[40];
//freopen("input","r",stdin);
while(scanf("%d",&n) && n!=0)
{
memset(map,0,sizeof(map));
memset(opt,0,sizeof(opt));
for(i=0;i<n;i++)
{
scanf("%s",cache);
for(j=2;cache[j]!='/0';j++)
{
map[i][cache[j]-'A']=1;
}
}
for(i=1;i<=4;i++)
{
if(DFS(0,i))//着色成功
break;
}
if(i==1) printf("1 channel needed./n");
else printf("%d channels needed./n",i);
}
return 0;
}

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息