您的位置:首页 > 产品设计 > UI/UE

hdu 3415 Max Sum of Max-K-sub-sequence 单调队列 求连续l(1<=l<=k)个数的和的最大值 数列可循环

2010-10-08 21:45 531 查看

Max Sum of Max-K-sub-sequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1188 Accepted Submission(s): 426


Problem Description
Given a circle sequence A[1],A[2],A[3]......A
. Circle sequence means the left neighbour of A[1] is A
, and the right neighbour of A
is A[1].
Now your job is to calculate the max sum of a Max-K-sub-sequence. Max-K-sub-sequence means a continuous non-empty sub-sequence which length not exceed K.

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases.
Then T lines follow, each line starts with two integers N , K(1<=N<=100000 , 1<=K<=N), then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output a line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the minimum start position, if still more than one , output the minimum length of them.

Sample Input

4
6 3
6 -1 2 -6 5 -5
6 4
6 -1 2 -6 5 -5
6 3
-1 2 -6 5 -5 6
6 6
-1 -1 -1 -1 -1 -1


Sample Output

7 1 3
7 1 3
7 6 2
-1 1 1#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int inf=(1<<31)-1;
int Q[210000],I[210000];//最小单调队列
int a[210000],sum[210000];
int main()
{
int ci;scanf("%d",&ci);
while(ci--)
{
int n,k;scanf("%d%d",&n,&k);
int start,end;
for(int i=1;i<=n;i++)
{
scanf("%d",&a[i]);
sum[i]=sum[i-1]+a[i];
}
for(int i=n+1;i<=2*n;i++) sum[i]=sum[i-1]+a[i-n];
int head=0,tail=-1;
int _max=-inf;
for(int j=1;j<n+k;j++)//枚举尾点 求sum[j]-sum[i-1] 的最大值(j-k=< i <= j-1)
{
int i=j-1;//sum[j-1]入队
while(head<=tail&&Q[tail]>=sum[i]) tail--;
tail++;
Q[tail]=sum[i];I[tail]=i;
i=j-k-1;//出队
while(head<=tail&&I[head]<=i) head++;
int _res=sum[j]-Q[head];//注意是Q[head]存最小值
if(_res>_max)
{
_max=_res;
start=I[head]+1,end=j;//注意是I[head]存最小值的坐标
if(end>n) end-=n;
}
}
printf("%d %d %d/n",_max,start,end);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: