您的位置:首页 > 其它

2107: Red and Black

2010-07-10 20:11 148 查看
2107: Red and Black

ResultTIME LimitMEMORY LimitRun TimesAC TimesJUDGE

3s8192K336184Standard
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile

'#' - a red tile

'@' - a man on a black tile(appears exactly once in a data set)

The end of the input is indicated by a line consisting of two zeros.

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13


This problem is used for contest: 17 150

#include<stdio.h>
#include<string.h>
int xx[4]={0,-1,1,0};
int yy[4]={-1,0,0,1};
char a[100][100];
int row,colum;
int count;
void dfs(int i,int j)
{
int k;
a[i][j]='#';
for(k=0;k<4;k++)
{
if(i+xx[k]<row&&i+xx[k]>=0&&j+yy[k]>=0&&j+yy[k]<colum&&a[i+xx[k]][j+yy[k]]=='.')
{
count++;
dfs(i+xx[k],j+yy[k]);
}
}
}
int main()
{
int i,j;
while(scanf("%d%d",&colum,&row)&&row&&colum)
{
for(i=0;i<row;i++)
{
scanf("%s",a[i]);
}
count=1;
int fa=0;
for(i=0;i<row;i++)
{
for(j=0;j<colum;j++)
{
if(a[i][j]=='@')
{
fa=1;
dfs(i,j);
break;
}
}
if(fa) break;
}
printf("%d/n",count);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: