您的位置:首页 > 编程语言 > Java开发

【JAVA】1002 A+B for Polynomials (25分) PAT甲级 PAT (Advanced Level) Practice

2020-05-10 04:15 417 查看

1002 A+B for Polynomials (25分)

This time, you are supposed to find A+B where A and B are two polynomials.

Input Specification:
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial:
K N1N_1N1​ aN1a_N1aN​1 N2N_2N2​ aN2a_N2aN​2… NKN_KNK​ aNKa_NKaN​K
每个输入文件包含一个测试用例。 每个案例占用2行,并且每行包含一个多项式的信息:
K N1N_1N1​ aN1a_N1aN​1 N2N_2N2​ aN2a_N2aN​2… NKN_KNK​ aNKa_NKaN​K

where K is the number of nonzero terms in the polynomial, NiN_iNi​andaNia_NiaN​i(i=1,2,⋯,K) are the exponents and coefficients, respectively. It is given that 1≤K≤10,0≤NKN_KNK​​<⋯<N2N_2N2​<N1N_1N1​≤1000.
其中K是多项式中非零项的数量,NiN_iNi​andaNia_NiaN​i(i=1,2,⋯,K) 分别是指数和系数。 假设1≤K≤10,0≤NKN_KNK​​<⋯<N2N_2N2​<N1N_1N1​≤1000.

Output Specification:
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
对于每个测试用例,应在一行中输出A和B的总和,格式与输入相同。 请注意,每行末尾不得有多余的空间。 请精确到小数点后一位。

Sample Input:
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output:
3 2 1.5 1 2.9 0 3.2

要点

  1. 最难理解的是题目

  2. 请注意,每行末尾不得有多余的空间。

  3. 请精确到小数点后一位。

    System.out.printf("%.1f", C[i]);
  4. 注意一个特殊样例,比如输入两行分别是
    1 2 1
    1 2 -1
    这就是x2x^2x2+−x2-x^2−x2,输出为0

代码

import java.util.Arrays;
import java.util.Scanner;

public class PolynomialAddition1 {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
Double[] A = new Double[1001];
for (int i = 0; i < 1001; i++) { //防止 C[i] = A[i] + B[i];发生空指针异常
A[i] = 0.0;
}
Double[] B = new Double[1001];
for (int i = 0; i < 1001; i++) {//防止 C[i] = A[i] + B[i];发生空指针异常
B[i] = 0.0;
}

int K = sc.nextInt();
int index;
while (K != 0) {
index = sc.nextInt(); //指数
A[index] = sc.nextDouble(); //系数
K--;
}
//        System.out.println(Arrays.toString(A));

K = sc.nextInt();
while (K != 0) {
index = sc.nextInt(); //指数
B[index] = sc.nextDouble(); //系数
K--;
}
sc.close();
//        System.out.println(Arrays.toString(B));

double[] C = new double[1001];
int count = 0;
/*//错误
for (int i = 0; i < 1001; i++) {
if (A[i] != 0 || B[i] != 0) {
//这得小心一种情况。输入的两行分别是 a:1 1 1  b:1 1 -1。
//A[1]+B[1]=0,这时count不应该再加
count++;
C[i] = A[i] + B[i];
}
}*/
//改正
for (int i = 0; i < 1001; i++) {
C[i] = A[i] + B[i];
if ((A[i] != 0 || B[i] != 0) && C[i] != 0) {
// 这得小心一种情况。输入的两行分别是 a:1 1 1  b:1 1 -1。
// A[1]+B[1]=0,这时count不应该再加
count++;
}
}
//        System.out.println(Arrays.toString(C));
System.out.print(count);
for (int i = 1000; i >= 0; i--) {
if (C[i] != 0) {
System.out.print(" " + i + " ");
System.out.printf("%.1f", C[i]);}
}
}
}
爱做梦的鱼 原创文章 169获赞 1083访问量 7万+ 关注 私信
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: