您的位置:首页 > 其它

PAT (Advanced Level) Practise 1002 A+B for Polynomials

2017-03-02 22:45 435 查看


1002. A+B for Polynomials (25)

时间限制

400 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where
K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5

Sample Output
3 2 1.5 1 2.9 0 3.2


解题思路:多项式相加

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <stack>
#include <queue>
#include <vector>
#include <map>

using namespace std;

const int INF=0x3f3f3f3f;
double a[1009];

int main()
{
int n;
while(~scanf("%d",&n))
{
memset(a,0,sizeof a);
int x;
double y;
for(int i=0;i<n;i++)
{
scanf("%d %lf",&x,&y);
a[x]+=y;
}
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d %lf",&x,&y);
a[x]+=y;
}
int sum=0;
for(int i=0;i<1006;i++)
if(a[i]) sum++;
printf("%d",sum);
for(int i=1005;i>=0;i--)
if(a[i]) printf(" %d %.1lf",i,a[i]);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: