您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表七:单链表中重复元素的删除

2019-03-17 22:39 253 查看
版权声明:本文为博主原创文章,遵循 CC 4.0 by-sa 版权协议,转载请附上原文出处链接和本声明。 本文链接:https://blog.csdn.net/abclvlvlv/article/details/88629018

数据结构实验之链表七:单链表中重复元素的删除
Time Limit: 1000 ms Memory Limit: 65536 KiB

Problem Description
按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。

Input

第一行输入元素个数 n (1 <= n <= 15); 第二行输入 n 个整数,保证在 int 范围内。

Output

第一行输出初始链表元素个数; 第二行输出按照逆位序所建立的初始链表; 第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。

Sample Input

10
21 30 14 55 32 63 11 30 55 30

Sample Output

10

30 55 30 11 63 32 55 14 30 21

7

30 55 11 63 32 14 21

Hint
Source
不得使用数组!

#include <stdio.h>
#include <stdlib.h>
struct node
{
int data;
struct node *next;
};
int main()
{
int n,i;
struct node *head,*p;
head=(struct node *)malloc(sizeof(struct node));
head->next=NULL;
scanf("%d",&n);
for(i=0;i<n;i++)
{
p=(struct node *)malloc(sizeof(struct node));
p->next=NULL;
scanf("%d",&p->data);
p->next=head->next;
head->next=p;
}
printf("%d\n",n);
p=head->next;
while(p)
{
if(p->next!=NULL)
printf("%d ",p->data);
else printf("%d\n",p->data);
p=p->next;
}
p=head->next;
struct node *q,*t;
while(p->next!=NULL)
{
q=p->next;
t=p;<
3ff8
/span>
while(q)
{
if(p->data==q->data)
{
q=q->next;
t->next=q;
n--;
}
else
{
q=q->next;
t=t->next;
}
}
if(p->next==NULL)    //不要忘记,否则结果会超时
break;
else  p=p->next;
}
printf("%d\n",n);
p=head->next;
while(p)
{
if(p->next!=NULL)
printf("%d ",p->data);
else printf("%d\n",p->data);
p=p->next;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: