您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表七:单链表中重复元素的删除

2019-02-21 20:12 169 查看

Problem Description
按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。

Input
第一行输入元素个数 n (1 <= n <= 15);
第二行输入 n 个整数,保证在 int 范围内。

Output
第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。

Sample Input
10
21 30 14 55 32 63 11 30 55 30
Sample Output
10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21
Hint
Source
不得使用数组!

#include <stdio.h>
#include <stdlib.h>
struct node
{
int data;
struct node *next;

};

struct node *creat(int n)
{
struct node *head,*p;
int i;
head=(struct node*)malloc(sizeof(struct node));
head->next=NULL;
for(i=0; i<n; i++)
{
p=(struct node*)malloc(sizeof(struct node));
scanf("%d",&p->data);
p->next=head->next;
head->next=p;

}
return head;
}
int shanchu(struct node *head,int n)
{
struct node *p,*q,*x;//p从头开始指向每一个元素,x负责将p所指的元素与后面所有的元素进行比较,p作为x前面的元素,为了方便删除
int m;
p=head->next;
m=n;
while(p!=NULL)
{
q=p;
x=q->next;
while(x!=NULL)
{
if(x->data==p->data)
{
q->next=x->next;
free(x);
x=q->next;
m--;

}
else
{
q=q->next;
x=x->next;

}
}
p=p->next;
}
return m;
}
void print(struct node *head)
{
struct node *p;
p=head->next;
while(p)
{
if(p->next!=NULL)printf("%d ",p->data);
else printf("%d\n",p->data);
p=p->next;

}

}
int main()
{
int n,m;
struct node *head;
scanf("%d",&n);
head=creat(n);
printf("%d\n",n);
print(head);
m=shanchu(head,n);
printf("%d\n",m);
print(head);

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: