您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之链表七:单链表中重复元素的删除

2017-10-18 16:31 239 查看


Problem Description

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。


Input

第一行输入元素个数 n (1 <= n <= 15);

第二行输入 n 个整数,保证在 int 范围内。


Output

第一行输出初始链表元素个数;

第二行输出按照逆位序所建立的初始链表;

第三行输出删除重复元素后的单链表元素个数;

第四行输出删除重复元素后的单链表。


Example Input

10
21 30 14 55 32 63 11 30 55 30



Example Output

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21


#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define ERROR -1
#define OVERFLOW -2
#define OK 1

typedef int Elemtype;
typedef int Statu;
typedef struct Lnode
{
Elemtype data;
struct Lnode *next;
} Link;

Link * Creat(int n);
Statu Del_Link(Link *head, int n);
Statu Dis_Link(Link *head);

int main()
{
int n;
Link *head;
scanf("%d", &n);
head = Creat(n);
printf("%d\n", n);
Dis_Link(head);
Del_Link(head, n);
Dis_Link(head);
return 0;
}
Link *Creat(int n)
{
Link *head, *p;
head = (Link *)malloc(sizeof(Link));
head -> next = NULL;
while(n--)
{
p = (Link *)malloc(sizeof(Link));
scanf("%d", &p -> data);
p -> next = head -> next;
head -> next = p;
}
return head;
}
Statu Del_Link(Link *head, int n)
{
Link *p, *q, *t;
p = head -> next;
while(p)
{
t = p;
q = p -> next;
while(q)
{
if(p -> data == q -> data)
{
t -> next = q -> next;
n--;
q = t -> next;
}
else
{
t = t -> next;
q = q -> next;
}
}
p = p -> next;
}
printf("%d\n", n);
return OK;
}
Statu Dis_Link(Link *head)
{
Link *p;
p = head -> next;
while(p -> next)
{
printf("%d ", p -> data);
p = p -> next;
}
printf("%d\n", p -> data);
return OK;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: