您的位置:首页 > 其它

Flip Game

2018-07-26 16:08 183 查看

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 

  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).


Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

题意:就是翻棋子,每次把它和它周围si'g四个方向的都翻过来,知道所有棋子都到同yi一面为止。可以输出最小翻的次数,不可以输出Impossible

思路:深搜一直翻就好了,每次需要判断下是不是都到同一个面了。

代码:

[code]#include<stdio.h>
#include<string.h>
#define INF 0x3f3f3f3f
char str[10];
int mp[10][10];
int step;
int check()        //检查是否已经所有棋子都是同一面
{
int x=mp[0][0];
for(int i=0; i<4; i++)
for(int j=0; j<4; j++)
{
if(mp[i][j]!=x) return 0;
}
return 1;
}
void fun(int x,int y)      //翻棋子
{
mp[x][y]=!mp[x][y];
if(x-1>=0)
mp[x-1][y]=!mp[x-1][y];
if(x+1<4) mp[x+1][y]=!mp[x+1][y];
if(y-1>=0)
mp[x][y-1]=!mp[x][y-1];
if(y+1<4) mp[x][y+1]=!mp[x][y+1];
}
void dfs(int x,int y,int t)
{
if(check())
{
if(step>t)
{
step=t;
return ;     //更新数据
}
}
if(x>=4||y>=4)
return ;
int dx=(x+1)%4;
int dy=y+(x+1)/4;     //行,列
dfs(dx,dy,t);
fun(x,y);
dfs(dx,dy,t+1);      //每个棋子有两种操作,翻或不翻
fun(x,y);
return ;
}
int main()
{
for(int i=0; i<4; i++)
{
scanf("%s",str);
for(int j=0; j<4; j++)
{
if(str[j]=='b')
mp[i][j]=0;
else
mp[i][j]=1;    //用0,1记录面,后面更容易判断
}
}
step=INF;
dfs(0,0,0);
if(step==INF)
printf("Impossible\n");
else
printf("%d\n",step);
}

 

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: