您的位置:首页 > 其它

02-线性结构3 Reversing Linked List(25 分)

2018-03-22 19:04 459 查看

02-线性结构3 Reversing Linked List(25 分)

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​5​​) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.
Then N lines follow, each describes a node in the format:
Address Data Next
where
Address
is the position of the node,
Data
is an integer, and
Next
is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218

Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

这道题想了好久,想出了一点头绪。关于翻转的部分还是看别人敲的代码才弄出来。

先说一下误区,
因为本题的输入的三个,而题目很明确的说了是让对链表进行翻转,所以自然而然想到了用一个结构体,结构体里定义三个变量,分别是当前地址,数值和下一个数字的地址。然后用结构数组+cmp+sort方法对结构体的数字按照从小到大进行排列。后来在实践中发现有问题,不仅表示的很麻烦,而且在后面的排序部分的cmp函数也很麻烦。
然后就又有一个想法,用当前的数字的值作为结构数组的下标,结构体里存放当前的地址和接下来next的地址
既然可以将data值作为数组下标,那么也可以将当前的地址值作为数组下标,结构体里存放当前的data值和next的地址

这个代码用的是后者+reverse函数  (头文件 #include <algorithm>)

#include <iostream>
#include <stdio.h>
#include <algorithm>
using namespace std;
const int maxn=1e6+15;
struct Node
{
int next;
int data;

}node[maxn+1];

int List[maxn+1];
int main()
{

int first,n,k;
int ddata,nnext,add;
cin>>first>>n>>k;
int p=first;
for(int i=0; i<n; i++)
{
cin>>add>>ddata>>nnext;
node[add].data=ddata;
node[add].next=nnext;
}

int j=0;                    

while(p!=-1)
{
List[j++]=p;
p=node[p].next;
}
int i=0;
while((i+k)<=j)
{
reverse(&List[i],&List[i+k]);
i=i+k;
}
for(int i=0; i<j-1; i++)
printf("%05d %d %05d\n",List[i],node[List[i]].data,List[i+1]);
printf("%05d %d -1\n",List[j-1],node[List[j-1]].data);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: