您的位置:首页 > 其它

hpu寒假训练D-Rikka with Chess 【思维&&找规律】

2018-03-01 19:07 344 查看
Yuta gives Rikka a chess board of size n×mn×m. 

As we all know, on a chess board, every cell is either black or white and every two cells that share a side have different colors. 

Rikka can choose any rectangle formed by board squares and perform an inversion, every white cell becomes black, and vice versa. 

Rikka wants to turn all cells into the same color, please tell Rikka the minimal number of inversions she need to achieve her goal.InputThe first line contains a number T(T≤10)T(T≤10) ——The number of the testcases. 

Each testcase contains two numbers n,m(n≤109,m≤109)n,m(n≤109,m≤109). 
OutputFor each testcase, print a single number which represents the answer.Sample Input
3
1 2
2 2
3 3
Sample Output
1
2
2

程序如下:#include<cstdio>
#include<algorithm>
using namespace std;
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
long long n;
long long m;
scanf("%lld%lld",&n,&m);
printf("%lld\n",n/2+m/2); //画图寻找规律
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: