您的位置:首页 > Web前端 > Node.js

1115. Counting Nodes in a BST (30)

2018-02-25 17:37 441 查看
1115. Counting Nodes in a BST (30)

时间限制 400 ms 内存限制 65536 kB 代码长度限制 16000 B

判题程序 Standard 作者 CHEN, Yue

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than or equal to the node’s key.

The right subtree of a node contains only nodes with keys greater than the node’s key.

Both the left and right subtrees must also be binary search trees.

Insert a sequence of numbers into an initially empty binary search tree. Then you are supposed to count the total number of nodes in the lowest 2 levels of the resulting tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=1000) which is the size of the input sequence. Then given in the next line are the N integers in [-1000 1000] which are supposed to be inserted into an initially empty binary search tree.

Output Specification:

For each case, print in one line the numbers of nodes in the lowest 2 levels of the resulting tree in the format:

n1 + n2 = n

where n1 is the number of nodes in the lowest level, n2 is that of the level above, and n is the sum.

Sample Input:

9

25 30 42 16 20 20 35 -5 28

Sample Output:

2 + 4 = 6

#define _CRT_SECURE_NO_WARNINGS
#include <algorithm>
#include <iostream>
#include <queue>

using namespace std;
const int MaxN = 1010;
int lLevelN = 0, aLevelN = 0;

typedef struct tnode
{
int val;
struct tnode * lchild;
struct tnode * rchild;
}TNode, *PTNode;

void InsertNode(PTNode  &root, int value)
{
if (!root)
{
root = new TNode;
root->val = value;
root->lchild = root->rchild = nullptr;
}
else if (value <= root->val)
InsertNode(root->lchild, value);
else
InsertNode(root->rchild, value);
}

PTNode CreateBST(int n, int data[])
{
PTNode root = nullptr;
for (int i = 0; i < n; ++i)
InsertNode(root, data[i]);

return root;
}

void LevelOrder(PTNode root)
{
if (root == nullptr) return;
queue<PTNode> que,backque; que.push(root);

while (que.size())
{
aLevelN = lLevelN;
lLevelN = 0;
while (que.size())
{
++lLevelN;
PTNode node = que.front(); que.pop();
if (node->lchild != nullptr) backque.push(node->lchild);
if (node->rchild != nullptr) backque.push(node->rchild);
delete node;
}
swap(que, backque);
}
}

int main()
{
#ifdef _DEBUG
freopen("data.txt", "r+", stdin);
#endif // _DEBUG

std::ios::sync_with_stdio(false);

int n,data[MaxN];
cin >> n;
for (int i = 0; i < n; ++i)
cin >> data[i];
PTNode root = CreateBST(n, data);
LevelOrder(root);
cout << lLevelN << " + " << aLevelN << " = " << aLevelN + lLevelN;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  pat甲级 1115