您的位置:首页 > 其它

POJ1144 Network (Tarjan算法求无向图的割点)

2018-02-18 22:18 435 查看

Network

Time Limit: 1000MS Memory Limit: 10000K

Total Submissions: 15194 Accepted: 6906

Description

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is

possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure

occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated

by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0;

Output

The output contains for each block except the last in the input file one line containing the number of critical places.
4000

Sample Input

5

5 1 2 3 4

0

6

2 1 3

5 4 6 2

0

0

Sample Output

1

2

Hint

You need to determine the end of one line.In order to make it’s easy to determine,there are no extra blank before the end of each line.

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAXN = 110;
const int WHITE = 0,GREY = 1,BLACK = 2;
int map[MAXN][MAXN];
int DFN[MAXN],low[MAXN],col[MAXN];
bool vis[MAXN];
int target[MAXN];
int n,ans;
void tarjan(int now, int father, int depth){
DFN[now] = depth;
col[now] = GREY;
int child = 0;
for(int i = 1; i <= n; i++){
if(map[now][i] == 0)continue;

if( i != father && col[i] == GREY){// i is u'grandfather
low[now] = min(low[now],DFN[i]);
}
if(col[i] == WHITE ){// i is u'child
tarjan(i,now,depth+1);
child++;
low[now] = min(low[i],low[now]);
if((now == 1 && child > 1) || (now != 1 && low[i] >= DFN[now])){//is ge dian
target[now] = 1;
//ans++;  //注意:需要记录该割点增加几个联通分量的操作需要在这里ans++
}
/*
if(low[i] > DEN[now]){
target[now][i] = 1;//now->i is ge edge;
}
*/
}
}
col[now] = BLACK;
}
int main(){
while(scanf("%d",&n)&&n){
int u,v;
memset(map,0,sizeof(map));
memset(col,0,sizeof(col));
memset(target,0,sizeof(target));
for(int i = 1; i <= n; i++){
low[i] = 99999999;//low[i] should initilized INT_MAX;
}
while(scanf("%d",&u) && u){
while(getchar() != '\n'){
scanf("%d",&v);
map[u][v] = map[v][u] = 1;
}
}
tarjan(1,1,0);
ans = 0;
int cnt = 0;
for(int i = 1; i <= n; i++){
if(target[i] == 1) {
cnt++;
}
}
cout<<cnt<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: