您的位置:首页 > 其它

ZOJ 3609 Modular Inverse(扩展欧几里得求逆元)

2018-02-15 09:20 405 查看
The modular modular multiplicative inverse of an integer a modulo m is an integer x such that 
a-1≡x (mod m)
. This is equivalent to 
ax≡1 (mod m)
.

Input

There are multiple test cases. The first line of input is an integer T ≈ 2000 indicating the number of test cases.Each test case contains two integers 0 < a ≤ 1000 and 0 < m ≤ 1000.

Output

For each test case, output the smallest positive x. If such x doesn't exist, output "Not Exist".

Sample Input

3
3 11
4 12
5 13

Sample Output

4
Not Exist
8#include<cstdio>
#include<cmath>
using namespace std;
typedef long long ll;
ll exten_gcd(ll a,ll b,ll& x,ll& y)
{
ll d=a;
if(b)
{
d=exten_gcd(b,a%b,y,x);
y-=a/b*x;
}
else x=1,y=0;
return d;
}
int main()
{
int T;scanf("%d",&T);
while(T--)
{
ll a,m;
scanf("%lld%lld",&a,&m);
ll x,y,s;
s=exten_gcd(a,m,x,y);
if(s!=1)printf("Not Exist\n");
else
{
x%=m;
if(x<=0)x+=m;
printf("%lld\n",x);//x可能等于m,开始写成(x%m+m)%m wa了
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: