您的位置:首页 > 其它

1135. Is It A Red-Black Tree (30)

2018-02-15 02:38 405 查看
There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:(1) Every node is either red or black.
(2) The root is black.
(3) Every leaf (NULL) is black.
(4) If a node is red, then both its children are black.
(5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.



Figure 1Figure 2Figure 3
For each given binary search tree, you are supposed to tell if it is a legal red-black tree.Input Specification:Each input file contains several test cases. The first line gives a positive integer K (<=30) which is the total number of cases. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.Output Specification:For each test case, print in a line "Yes" if the given tree is a red-black tree, or "No" if not.Sample Input:
3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17
Sample Output:
Yes
No
No

#include <iostream>
using namespace std;
#define N 31

struct node {
int value;
struct node *left, *right;
};

node* buildTree(int *pre, int start, int end){
if(start == end) return NULL;
int i;
for (i = start; i < end; i++)//找到比pre[start]大的第一个位置后停止 根据二叉搜索树的性质,该位置右侧的数在右子树上
if(abs(pre[i]) > abs(pre[start])) break;
node *root = new node();//建立"根节点"
root->value = pre[start];
root->left = buildTree(pre, start+1, i);//递归建立左子树
root->right = buildTree(pre, i, end);//递归建立右子树
return root;
}

int postOrder(node* root){//后续遍历检查路径上是否由相同的黑色节点数量
if (root) {
int leftBlack = postOrder(root->left);
int rightBlack = postOrder(root->right);
if (leftBlack < 0 || rightBlack < 0 || rightBlack != leftBlack)
return -1;
else if(root->value < 0)
return leftBlack;
else
return leftBlack + 1;
}
return 0;
}

int previousOrder(node *root){//前序遍历用以检查是否有连续的两个红色节点
if (root) {
if (root->value < 0) {//红色节点
if (root->left)//左节点为红色
if (root->left->value < 0)
return 1;
if (root->right)//右节点为红色
if (root->right->value < 0)
return 1;
}
return previousOrder(root->left) || previousOrder(root->right);//递归进行检查
}
return 0;
}

int main(){
int k, n, pre
;
cin >> k;
for (int i = 0; i < k; i++) {
cin >> n;
fill(pre, pre + n, 0);
for (int j = 0; j < n; j++) {
cin >> pre[j];
}
if (pre[0] < 0) {//负号代表红色节点,不符合要求
cout << "No\n";
continue;
}
node *root = buildTree(pre, 0, n);
//balance用来存储路径的黑色节点是否相同,非负数相同,负数(-1)代表数量不相同
int balance = postOrder(root);
//continous用来存储两个红色的节点是否连续,1代表连续,
int continuous = previousOrder(root);
//如果路径上黑色节点数量不同或者存在连续的红色节点
if (balance < 0 || continuous == 1)
cout << "No\n";
else
cout << "Yes\n";
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: