您的位置:首页 > 产品设计 > UI/UE

2018_2_12_Ubiquitous Religions_并查集

2018-02-12 14:03 260 查看
Ubiquitous Religions
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 38587 Accepted: 18391
DescriptionThere are so many different religions in the world today that it is difficult to keep track of them all. You are interested in finding out how many different religions students in your university believe in.

You know that there are n students in your university (0 < n <= 50000). It is infeasible for you to ask every student their religious beliefs. Furthermore, many students are not comfortable expressing their beliefs. One way to avoid these problems is to ask m (0 <= m <= n(n-1)/2) pairs of students and ask them whether they believe in the same religion (e.g. they may know if they both attend the same church). From this data, you may not know what each person believes in, but you can get an idea of the upper bound of how many different religions can be possibly represented on campus. You may assume that each student subscribes to at most one religion. InputThe input consists of a number of cases. Each case starts with a line specifying the integers n and m. The next m lines each consists of two integers i and j, specifying that students i and j believe in the same religion. The students are numbered 1 to n. The end of input is specified by a line in which n = m = 0. OutputFor each test case, print on a single line the case number (starting with 1) followed by the maximum number of different religions that the students in the university believe in.Sample Input10 9
1 2
1 3
1 4
1 5
1 6
1 7
1 8
1 9
1 10
10 4
2 3
4 5
4 8
5 8
0 0
Sample OutputCase 1: 1
Case 2: 7
HintHuge input, scanf is recommended.SourceAlberta Collegiate Programming Contest 2003.10.18#include<iostream>
#include<cstdio>
#include<cstring>
#include<set>
#include<algorithm>
using namespace std;
const int N=5e5+10;
int sset
;

int set_find(int x){
if(sset[x]==-1)return x;
return sset[x]=set_find(sset[x]);
}

int main(){
int n,m;
int z=1;
while(scanf("%d%d",&n,&m),n||m){
memset(sset,-1,sizeof(sset));
int x,y;
while(m--){
scanf("%d%d",&x,&y);
x=set_find(x);
y=set_find(y);
if(x!=y){
sset[x]=y;
}
}
set<int> s;
for(int i=1;i<=n;i++)
s.insert(set_find(i));
printf("Case %d: %d\n",z++,s.size());
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: