您的位置:首页 > 其它

[poj3292]Semi-prime H-numbers(数论,素数)

2018-02-11 23:01 399 查看

Semi-prime H-numbers

Time Limit: 1000MS

Memory Limit: 65536K

Description

This problem is based on an exercise of David Hilbert, who pedagogically suggested that one study the theory of 4n+1 numbers. Here, we do only a bit of that.

An H-number is a positive number which is one more than a multiple of four: 1, 5, 9, 13, 17, 21,… are the H-numbers. For this problem we pretend that these are the only numbers. The H-numbers are closed under multiplication.

As with regular integers, we partition the H-numbers into units, H-primes, and H-composites. 1 is the only unit. An H-number h is H-prime if it is not the unit, and is the product of two H-numbers in only one way: 1 × h. The rest of the numbers are H-composite.

For examples, the first few H-composites are: 5 × 5 = 25, 5 × 9 = 45, 5 × 13 = 65, 9 × 9 = 81, 5 × 17 = 85.

Your task is to count the number of H-semi-primes. An H-semi-prime is an H-number which is the product of exactly two H-primes. The two H-primes may be equal or different. In the example above, all five numbers are H-semi-primes. 125 = 5 × 5 × 5 is not an H-semi-prime, because it’s the product of three H-primes.

Input

Each line of input contains an H-number ≤ 1,000,001. The last line of input contains 0 and this line should not be processed.

Output

For each inputted H-number h, print a line stating h and the number of H-semi-primes between 1 and h inclusive, separated by one space in the format shown in the sample.

Sample Input

21
85
789
0


Sample Output

21 0
85 5
789 62


Source

Waterloo Local Contest, 2006.9.30

解题思路

题意理解了好一会儿……不过还是一道挺有趣的题

我们发现,与我们通常所讨论的正整数域相比,这道题只不过是把数域缩小为所有4n+14n+1形式的正整数构成的集合上而已,素数、合数在新的数域上的定义并没有改变,那么我们在正整数域是怎么做的,在这道题里如法炮制就行了。

发现,在线性筛筛出素数的同时,可以顺便把所谓的semi-prime处理出来(见代码),最后前缀和优化一下以便O(1)O(1)回答查询

Code

#include<cstdio>

using namespace std;

const int N = 1e6+5;
int h;
int pList
, pNum, cnt
;
bool notP
, isHsp
;
void Euler(){
notP[1] = 1;
for(int i = 1; i <= 1e6+1; i += 4){
if(!notP[i])    pList[++pNum] = i;
for(int j = 1; j <= pNum; j++){
if(pList[j] * i > 1e6+1)    break;
notP[pList[j]*i] = 1;
if(!notP[i])    isHsp[pList[j]*i] = 1;//处理出semi-prime
if(i % pList[j] == 0)   break;
}
}
}

int main(){
Euler();
for(int i = 1; i <= 1e6+1; i++)
cnt[i] = cnt[i-1] + isHsp[i];
while(scanf("%d", &h) && h)
printf("%d %d\n", h, cnt[h]);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: