您的位置:首页 > 其它

POJ 3264 Balanced Lineup 区间查询(两棵树求最大最小值)

2018-02-09 11:14 381 查看
For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input
Line 1: Two space-separated integers, N and Q. 
Lines 2.. N+1: Line i+1 contains a single integer that is the height of cow i 
Lines N+2.. N+ Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.
Output
Lines 1.. Q: Each line contains a single integer that is a response to a reply and indicates the difference in height between the tallest and shortest cow in the range.
Sample Input
6 3
1
7
3
4
2
5
1 5
4 6
2 2
Sample Output
6
3
0
题意:给出n个奶牛和m次查询,n个奶牛的高度,查询[a,b]最大值-最小值
思路:2个线段树分别求最大值和最小值
#include <iostream>
#include <cstdio>
#include <map>
#include <cstring>
#include <string>
#include <algorithm>
#include <cmath>
#include <set>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
const int maxn=50005;
const int INF = 1<<30;
int summax[maxn<<2];
int summin[maxn<<2];
void PushUPmax(int rt)
{//把子节点的信息更新到当前节点rt
summax[rt]=max(summax[rt<<1],summax[rt<<1|1]);
}
void PushUPmin(int rt)
{//把子节点的信息更新到当前节点rt
summin[rt]=min(summin[rt<<1],summin[rt<<1|1]);
}
void build(int l,int r,int rt)
{
if(l==r)
{
scanf("%d",&summax[rt]);
summin[rt]=summax[rt];
return ;
}
int m=(l+r)>>1;
build(lson);
build(rson);
PushUPmax(rt);
PushUPmin(rt);
}
int querymax(int L,int R,int l,int r,int rt)
{
if(L<=l&&r<=R){
return summax[rt];
}
int m=(l+r)>>1;
int ret=0;
if(L<=m) ret=max(ret,querymax(L,R,lson));
if(R>m) ret=max(ret,querymax(L,R,rson));
return ret;
}
int querymin(int L,int R,int l,int r,int rt)
{
if(L<=l&&r<=R){
return summin[rt];
}
int m=(l+r)>>1;
int ret=INF;
if(L<=m) ret=min(ret,querymin(L,R,lson));
if(R>m) ret=min(ret,querymin(L,R,rson));
return ret;
}
int main()
{
int n,m;
while(scanf("%d%d",&n,&m)==2)
{
int a,b;
char op[10];
build(1,n,1);
while(m--){
scanf("%d%d",&a,&b);
printf("%d\n",querymax(a,b,1,n,1)-querymin(a,b,1,n,1));
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: