您的位置:首页 > 其它

POJ3278 Catch That Cow

2018-02-08 12:10 253 查看
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.
* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.
If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
InputLine 1: Two space-separated integers: N and KOutputLine 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.Sample Input
5 17
Sample Output
4
HintThe fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.bfs解题:
#include<iostream>  
#include<queue>  
#include<cstring>  
#include<cstdio>  
using namespace std;  
  
const int maxn=100001;  
  
bool vis[maxn];//标记数列 
int step[maxn];//记录步数的数列 
queue <int> q;//队列 
  
int bfs(int n,int k)  
{  
    int head,next;  //表示当前一步和后一步的位置 
    q.push(n);  //从n出发,将n推入队列 
    step
=0;  
    vis
=true;  
    while(!q.empty())   
    {  
        head=q.front();//将当前一部从队列的首项拿出  
        q.pop();//将当前的位置弹出  
        for(int i=0;i<3;i++) //表示三种可能  
        {  
            if(i==0) next=head-1;//向左走1步  
            else if(i==1) next=head+1; //向右走一步 
            else next=head*2; //直接乘2 
            if(next<0 || next>=maxn) continue; //判断是否越界 
            if(!vis[next])//判断是否访问过(没有的情况下)   
            {  
                q.push(next);//将其放入队列   
                step[next]=step[head]+1;//步数加1  
                vis[next]=true; //变为访问过  
            }  
            if(next==k) return step[next]; //直到访问结束,返回步数  
        }  
    }  
}  
int main()  
{  
    int n,k;  
    while(cin>>n>>k)  
    {  
        memset(step,0,sizeof(step)); //初始化 
        memset(vis,false,sizeof(vis));  
          
        while(!q.empty()) q.pop(); 
        if(n>=k) printf("%d\n",n-k);  
        else printf("%d\n",bfs(n,k));  
    }  
    return 0;  
}  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM BFS POJ