您的位置:首页 > 其它

//用scanf和printf输入输出string//map的应用//Babelfish------三C

2018-02-07 17:23 232 查看
You have just moved from Waterloo to a big city. The people here speak an incomprehensible dialect of a foreign language. Fortunately, you have a dictionary to help you understand them.

Input

Input consists of up to 100,000 dictionary entries, followed by a blank line, followed by a message of up to 100,000 words. Each dictionary entry is a line containing an English word, followed by a space and a foreign language word. No foreign word appears more than once in the dictionary. The message is a sequence of words in the foreign language, one word on each line. Each word in the input is a sequence of at most 10 lowercase letters.

Output

Output is the message translated to English, one word per line. Foreign words not in the dictionary should be translated as “eh”.

Sample Input

dog ogday

cat atcay

pig igpay

froot ootfray

loops oopslay

atcay

ittenkay

oopslay

Sample Output

cat

eh

loops

解题思路:

这道题过程不难,主要就是数据量大需要用scanf和printf输入输出,因为有map所以需要用string类型。

一开始不知道怎么样scanf和printf输入输出string型所以一直有问题。

string类型中有一个.c_str()函数,能返回当前字符串的首地址。

printf(“%s”,s.c_str());就可以了

输入的话需要先用.resize预分配空间,然后再用scanf(“%s”,&s[0]);就可以了。

参考了这两篇博客

http://blog.csdn.net/spaceyqy/article/details/24840215

https://www.cnblogs.com/Annetree/p/6501559.html

#include<stdio.h>
#include<string>
#include<map>
using namespace std;

map<string,string> dic;

int main()
{
string a,b;
a.resize(15);
b.resize(15);
while(1)
{
scanf("%s",&a[0]);
if(dic.count(a)==1)
{
break;
}
scanf("%s",&b[0]);
dic[b]=a;
}
if(dic[a]!="")printf("%s\n",dic[a].c_str());
else printf("eh\n");
while(scanf("%s",&a[0])!=EOF)
{
if(dic[a]!="") printf("%s\n",dic[a].c_str());
else printf("eh\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: