您的位置:首页 > 其它

[UVa 489]Hangman Judge 刽子手游戏

2018-02-05 15:10 302 查看
In “Hangman Judge,” you are to write a program that judges a series of Hangman games. For each game, the answer to the puzzle is given as well as the guesses. Rules are the same as the classic game of hangman, and are given as follows:

The contestant tries to solve to puzzle by guessing one letter at a time.

Every time a guess is correct, all the characters in the word that match the guess will be “turned over.” For example, if your guess is “o” and the word is “book”, then both “o”s in the solution will be counted as “solved.”

Every time a wrong guess is made, a stroke will be added to the drawing of a hangman, which needs 7 strokes to complete. Each unique wrong guess only counts against the contestant once.

| |

| O

| /|\

| |

| / \

_|

| |__

|___|

If the drawing of the hangman is completed before the contestant has successfully guessed all the characters of the word, the contestant loses.

If the contestant has guessed all the characters of the word before the drawing is complete, the contestant wins the game.

If the contestant does not guess enough letters to either win or lose, the contestant chickens out.

Your task as the “Hangman Judge” is to determine, for each game, whether the contestant wins, loses, or fails to finish a game.

Input

Your program will be given a series of inputs regarding the status of a game. All input will be in lower case. The first line of each section will contain a number to indicate which round of the game is being played; the next line will be the solution to the puzzle; the last line is a sequence of the guesses made by the contestant. A round number of -1 would indicate the end of all games (and input).

Output

The output of your program is to indicate which round of the game the contestant is currently playing as well as the result of the game. There are three possible results:

You win.

You lose.

You chickened out.

Sample Input

1

cheese

chese

2

cheese

abcdefg

3

cheese

abcdefgij

-1

Sample Output

Round 1

You win.

Round 2

You chickened out.

Round 3

You lose.

题意:给两个字符串,如果第二个字符串的前七个字符包括了第一个字符串的所有种类的字符,就输出”You win.”,如果不包括但在后面的字符串里将第一个字符串的所有字符种类包括了则输出”You lose.”,否则输出”You chickened out.”。

解题思路:这道题很明显就是一道字符串处理问题,我们枚举第二个字符串的每一位,将第一个字符串中的每一位都与其比较,一样则将第一个字符串相应的位置变成空,不断递归下去,最后输出答案。

代码

#include<bits/stdc++.h>
using namespace std;
const int maxn=100;
int rnd,rest,chance=7,len;
bool win,lose;
char s1[maxn],s2[maxn];
int read()
{
int x=0,f=1;
char ch=getchar();
while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
return x*f;
}
void guess(char ch)
{
int bad=1;
for(int i=0;i<strlen(s1);i++)
if(s1[i]==ch){rest--;s1[i]=' ';bad=0;}
if(bad)chance--;
if(!chance)lose=1;
if(!rest)win=1;
}
int main()
{
while(1)
{
rnd=read();if(rnd==-1)break;
scanf("%s%s",s1,s2);
printf("Round %d\n",rnd);
win=lose=0;rest=strlen(s1);len=strlen(s2);
for(int i=0;i<len;i++)
{
guess(s2[i]);
if(win||lose)break;
}
if(win)puts("You win.");
else if(lose)puts("You lose.");
else puts("You chickened out.\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  递归 字符串