您的位置:首页 > 其它

AtCoder Beginner Contest 084 D - 2017-like Number (区间问题 a[r]-a[l-1])

2017-12-31 11:09 447 查看
Problem Statement

We say that a odd number N is similar to 2017 when both N and (N+1)⁄2 are prime.

You are given Q queries.

In the i-th query, given two odd numbers li and ri, find the number of odd numbers x similar to 2017 such that li≤x≤ri.

Constraints

1≤Q≤105

1≤li≤ri≤105

li and ri are odd.

All input values are integers.

Input

Input is given from Standard Input in the following format:

Q

l1 r1

:

lQ rQ

Output

Print Q lines. The i-th line (1≤i≤Q) should contain the response to the i-th query.

Sample Input 1

1

3 7

Sample Output 1

2

3 is similar to 2017, since both 3 and (3+1)⁄2=2 are prime.

5 is similar to 2017, since both 5 and (5+1)⁄2=3 are prime.

7 is not similar to 2017, since (7+1)⁄2=4 is not prime, although 7 is prime.

Thus, the response to the first query should be 2.

Sample Input 2

4

13 13

7 11

7 11

2017 2017

Sample Output 2

1

0

0

1

Note that 2017 is also similar to 2017.

Sample Input 3

6

1 53

13 91

37 55

19 51

73 91

13 49

Sample Output 3

4

4

1

1

1
2

题意:判断[l,r]内与2017类似的数字,2017的性质:2017为素数,(2017+1)/2仍为素数。

思路:打表算出来1-10^5内各自的数字,然后结果为a[r]-a[l-1].(区间问题一直是我的一个弱项,类似于[l,r]找是3和7的倍数是多少个的问题,我在HNUST上WA了20发!!!!)

#include <iostream>
#include <cstdio>
#include <algorithm>
#include <set>
#include <string>
#include <cstring>
#include <cmath>
#include <map>
#define N 100005
using namespace std;
typedef long long ll;
int vis
,a
;
void creat()
{
for(int i=2; i<=400; i++)
{
if(!vis[i])
{
for(int j=i*2; j<=N; j+=i)
vis[j]=1;
}
}
}
int main()
{

memset(vis,0,sizeof(vis));
creat();
vis[1]=1;
int sum=0,n;
for(int i=1; i<=N; i++)
{
if(i%2==1)
{
if(vis[i]==0&&vis[(i+1)/2]==0)
sum++;
}

a[i]=sum;
}
while(scanf("%d",&n)==1)
{
while(n--)
{
int c,b;
scanf("%d%d",&c,&b);

printf("%d\n",a[b]-a[c-1]);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐