您的位置:首页 > 其它

二分图 匈牙利算法 HDU2444 The Accomodation of Students

2017-12-14 12:23 417 查看


The Accomodation of Students

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 7573    Accepted Submission(s): 3359


Problem Description

There are a group of students. Some of them may know each other, while others don't. For example, A and B know each other, B and C know each other. But this may not imply that A and C know each other.

Now you are given all pairs of students who know each other. Your task is to divide the students into two groups so that any two students in the same group don't know each other.If this goal can be achieved, then arrange them into double rooms. Remember, only
paris appearing in the previous given set can live in the same room, which means only known students can live in the same room.

Calculate the maximum number of pairs that can be arranged into these double rooms.

 

Input

For each data set:

The first line gives two integers, n and m(1<n<=200), indicating there are n students and m pairs of students who know each other. The next m lines give such pairs.

Proceed to the end of file.

 

Output

If these students cannot be divided into two groups, print "No". Otherwise, print the maximum number of pairs that can be arranged in those rooms.

 

Sample Input

4 4
1 2
1 3
1 4
2 3
6 5
1 2
1 3
1 4
2 5
3 6

 

Sample Output

No
3

 

先用染色法判断是否为二分图,如果不是可以直接NO了,然后再用匈牙利算法算一下有几对,最后要/2哦。

#include<stdio.h>
#include<string.h>
#include<queue>
#include<iostream>
using namespace std;
int map[205][205],vis[205],color[205],n,duix[205];
bool bfs()
{
queue<int>q;
memset(color,0,sizeof(color));
q.push(1);
color[1]=1;
while(!q.empty())
{
int p=q.front();
q.pop();
for(int j=1;j<=n;j++)
{
if(map[p][j])
{
if(color[j]==0)
{
color[j]=-color[p];
q.push(j);
}
else if(color[j]==color[p])
return false;
}
}
}
return true;
}
int find(int i)
{
for(int j=1;j<=n;j++)
if(!vis[j]&&map[i][j])
{
vis[j]=1;
if(duix[j]==0||find(duix[j]))
{
duix[j]=i; return 1;
}
}
return 0;
}
int main()
{
int m,a,b,i,ans;
while(scanf("%d%d",&n,&m)!=EOF)
{
memset(map,0,sizeof(map));
memset(duix,0,sizeof(duix));
for(i=0;i<m;i++)
{
scanf("%d%d",&a,&b);
map[a][b]=map[b][a]=1;
}
if(!bfs()||n==1)
printf("No\n");
else
{
ans=0;
for(i=1;i<=n;i++)
{
memset(vis,0,sizeof(vis));
ans+=find(i);
}
printf("%d\n",ans/2);
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息