您的位置:首页 > 其它

Find The Multiple-POJ-1426-BFS

2017-12-06 20:59 405 查看
Find The Multiple

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 35763 Accepted: 14944 Special Judge
Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing
no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them
is acceptable.
Sample Input
2
6
19
0

Sample Output
10
100100100100100100
111111111111111111

Source
Dhaka 2002
[Submit]   [Go Back]   [Status]   [Discuss]

分析:这题放在搜索,BFS暴力居然过了;

AC code:

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <stack>
#include <string>
#include <map>
using namespace std;
#define LL __int64
#define INF 0x3f3f3f3f
#define eps 1
const int mod=1000000000+7;
const int maxn=1000000+50;

void bfs(int n){
queue<LL> q;
q.push(1);
while(!q.empty()){
LL s=q.front(); q.pop();
if(s%n==0) {
printf("%I64d\n",s );
return;
}
q.push(s*10);
q.push(s*10+1);
}
}

int main() {
int n;
while(~scanf("%d",&n)&&n){
bfs(n);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: